Web-Gui nicht mehr erreichbar nach Update 2.3.3



  • Guten Tag

    Frage eines Dumb-Users:

    Nach Update auf 2.3.3 meiner Pfsense (Alix 2D13 Basis) und nach jahrelangem problemlosen Betrieb,
    komme ich nicht mehr per Browser (FF, Opera, IE) auf das Web Gui, was vorher immer funktionierte.
    Die Eingabe der IP gibt immer Timeout. Das Update hatte ich im Webgui angestossen.

    Auch nach Dursicht/Suche in Foren komme ich nicht weiter. Was ist zu tun, damit der Zugriff per
    Browser wieder klappt?

    Vielen Dank für Hilfe.

    (2.3.3 ist natürlich gemeint, sorry)


  • Moderator

    Neugestartet hast du schon? Geht ein Zugriff per Konsole oder via SSH so dass du ggf. den WebConfigurator neustarten könntest?



  • Vielen Dank für die Antwort.

    Die Pfsense läuft in einem kleinen Netzwerk und wird oft ausgeschaltet und morgens wieder gestartet. Inzwischen ist dies mehrere Male geschehen.

    Der Zugriff per Konsole geht problemlos. Sonst läuft auch alles wie gehabt. Ich hätte einfach gerne die Kontrolle per Webgui zurück.
    In der Konsole/Shell habe ich nach Tip von hier:

    https://forum.pfsense.org/index.php?topic=126118.0

    pkg update -f
    pkg upgrade -f

    durchgeführt, auf die Gefahr hin, das Ding neu aufsetzen zu müssen. Dies hat aber nicht geholfen.
    Leider bin ich hier wirklich mehr der Anwender als ein Linux Spezialist…
    Den WebConfigurator habe ich bis jetzt (noch) nicht angefasst.



  • Nochmals…
    Nach Start des Webconfigurators/11 in der Konsole gibt es folgende Antwort:

    Restarting webConfigurator...
    Message from syslogd@pfSense at Mar  5 15:03:36 ...

    pfSense nginx: 2017/03/05 15:03:36 [emerg] 70736#100109: bind() to 0.0.0.0:443 failed (48: Address already in use)
    Message from syslogd@pfSense at Mar  5 15:03:36 …

    10x diese Message...
    dann:

    pfSense nginx: 2017/03/05 15:03:36 [emerg] 70736#100109: still could not bind()
    done.

    Was ist damit anzufangen?



  • Moin,

    das sagt das Du dort einen Dienst laufen hast der den Port 443 bereits nutzt.

    HornetX11



  • Guten Tag,

    Also Port 443 wird ja von https benutzt, jedenfalls ging der Zugriff per Browser früher so.

    Sieht es hier nicht so aus, also ob "jemand" anderes diesen Port schon "besetzt", Dienst oder sonst was ?
    Da der Zugriff per Konsole geht, werde ich mal den Punkt 14 (Enable ssh) probieren und sehen, ob ich als IT-Laie so weiterkomme.
    Oder gibts andere Vorschläge von den Spezialisten?

    Grüsse pf-user


  • Moderator

    Also Port 443 wird ja von https benutzt, jedenfalls ging der Zugriff per Browser früher so.

    Natürlich ist der Zugriff auf die WebGUI per HTTPS/443 wenn nicht anders konfiguriert. Die Log Meldungen sagen aber, dass sich der Nginx Webserver nicht auf den Port binden kann weil er bereits belegt ist. Entweder versucht sich Nginx 2x zu starten - was auf ein unvollständiges Update oder Problem mit der Installation hinweisen könnte - oder jemand/du hast noch ein anderes Paket installiert, dass sich ebenfalls gern auf 443 bindet und zuerst gestartet wurde. Das sind meist Dinge wie Web Proxies, Loadbalancer etc.

    Ansonsten würde ich wirklich mal die SSH Konsole aktivieren und nachsehen, was für Prozesse laufen und wer bspw. an tcp/443 gebunden ist wenn nicht nginx.

    Grüße



  • Hallo zusammen,

    ich habe leider seit dem Update genau das gleiche Problem "still could not bind() done." - jedoch auf Port 80 (443 für WebGUI nicht in Verwendung).

    wenn ich mit "sockstat -4 -p 80" per SSH abfrage, erhalte ich folgendes Ergebnis:

    USER    COMMAND    PID  FD PROTO  LOCAL ADDRESS        FOREIGN ADDRESS
    nobody  dnsmasq    16385 4  udp4  *:80                  :
    nobody  dnsmasq    16385 5  tcp4  *:80                  :

    Wenn ich das richtig verstehe, lauscht DNSMASQ auch auf Port 80. Soll er das? Kann man den ohne WebGUI deaktivieren?

    Vielen Dank für eure Hilfe  :)

    Gruß


  • Moderator

    hmm kannst du mal mit "ps" nachschauen, welche ID der dnsmasq hat, den mit "kill" wegschießen (testhalber) und dann den WebConfigurator (und ggf. php) neu starten lassen, ob das das Problem erstmal umgeht?



  • Guten Tag,
    In meinem Fall sieht dies so aus:

    USER    COMMAND    PID  FD PROTO  LOCAL ADDRESS        FOREIGN ADDRESS
    nobody  dnsmasq    20277 4  udp4  *:443                :
    nobody  dnsmasq    20277 5  tcp4  *:443                :

    Vorher habe ich mal ein Reboot geloggt. Hier fällt dies auf:

    snip–------
    Synchronizing user settings...done.
    Starting webConfigurator...failed!
    Configuring CRON...done.
    Starting NTP time client...done.
    snip----------

    Möglicherweise ging was schief beim Update.
    Unterdessen habe ich mir ein neues Image erstellt und getestet. Dies läuft bis jetzt einwandfrei. Auch das Webgui ist erreichbar (https).

    Jedenfalls ist das Problem für mich im Moment "gelöst".
    Danke an JeGr und TM.
    @TM: Du kannst hier weiter machen...

    Grüsse und viel Erfolg!



  • Danke JeGr! Das war der entscheidende Punkt.

    ein "ps -auxww" ergab:

    USER  PID  %CPU  %MEM  VSZ  RSS  TT  STAT  STARTED  TIME  COMMAND
    […]
    nobody  36263  0.0  0.1  30188  4224  -  I    Wed07PM    0:00.03 /usr/local/sbin/dnsmasq –all-servers -C /dev/null --rebind-localhost-ok --stop-dns-rebind --port=80 --listen-address=192.168.2.1 --dns-forward-max=5000 --cache-size=10000 --local-ttl=1
    […]

    kill 36263

    Neustart -> webcmd - funktioniert wieder :-)

    Scheinbar waren meine Einstellungen im "DNS Forwarder" nicht ganz korrekt. Jetzt habe ich den Host Override mit dem "DNS Resolver" gelöst und alles läuft problemlos.

    Vielen Dank für eure Unterstützung!  8)