Installation failed with mirrored drives and custom subpartitions using 2.3.3.



  • Good day to everyone!

    I`ve taken upon myself an installation of pfsense 2.3.3 and am using the iso installer.

    I have 2 SSD disks, that I mirrored during the installation. Next I marked to use the mirror as drive to install pfsense on. I left it with only one partition, but created my own subpartitions:

    /boot      512M
    /              16G
    swap      1024M
    /var        *

    After creating the subpartitions some code is being run at which step I come upon an error:

    Executing 'cd /dev && /bin/test -c pdSenseMirrors1d || /bin/sh MAKEDEV pfSenseMirrors1d'
    | MAKEDEV: Can`t open MAKEDEV: No such file or directory
      –> Exit status: 2

    This stops the installation.

    What could be causing this?

    Thanks for any help in advance!

    UPDATE:
    Same thing happens with 2.3.2 Installer.

    UPDATE 2
    Tried zeroing the first MB of both disks before install. Same error message.
    Tried installing with quick install and that worked, but that is not what I need, since I need to mirror disks and custom partition the system.

    UPDATE 3
    Tried replacing the /var subpartition size to calculated rest of disk instead of *. Same error occurred.

    UPDATE 4
    Tried the exact same setup in virtualbox and it fails there too.

    UPDATE 5
    I tried a setup where I do everything the same way except for subpartitions. Left it with default size swap and * for root (only 2 subpartitions) and it worked. So It doesnt like /var or /boot? Tried with any of the 2 to no avail. So /var nad /boot are not supported? Where can I find information on what partitions are supported then? been looking around and in the docs and see nothing. This starts looking really bad. How come I cant assign my own partitions to mount points?


  • Banned

    You don't do any such thing,. Simple.



  • @doktornotor:

    You don't do any such thing,. Simple.

    Just to clarify: I`m not supposed to create custom subpartitions in my installation?
    Why is the Custom install even there in that case?

    And thank You for your response, although You could have been clearer with the response.


  • Banned

    Custom partitioning is not supported and never worked. If you want to mess with things, try the new installer in 2.4 snapshots.



  • Should I remove this topic as it seems to be resolved?