Can't sync between 2.3.2-p1 and 2.3.3 ??



  • Trying to upgrade a HA pair to the latest, bumped the secondary to 2.3.3
    Now I see the primary isn't syncing -
    /rc.filter_synchronize: The other member is on a different configuration version of pfSense. Sync will not be done to prevent problems!
    Has CARP changed that much in 2.3.3?
    Kind of a PITA- Now when I update the primary, my config is going to be stale until the primary is back.
    I thought the sync was only disabled between major versions.


  • Rebel Alliance Developer Netgate

    It's disabled when the configuration format is different between them, as marked by the "<version>XX.Y</version>" in config.xml

    If the configuration version is different, they cannot sync because it could push incorrect data.

    That said, synchronizing between different versions has never been officially supported, nor recommended. It may have worked by chance before, but we never recommend running different versions for any measurable amount of time. Just long enough to make sure the updated node is functional/tested, which shouldn't involve any configuration changes.