Make WDS work while PFsense serve as DHCP and DNS

  • Hi,

    I was looking to solve an issue that I was experiencing the issue was, to be able to boot using PXE and load Windows 10 images from WDS/MDT in my case I was getting the error "no response from windows deployment services server gateway" few times and I found part of the solution here and the other part by trying n doing so I thought why not share it?.

    My configuration and I won't get into much details:
    1. WDS MS 2012 on VMware.
    1. Domain controller 2016 also VM (no DHCP activated DNS is only active for another vlan so I couldn't set the dhcp options on the DC wouldn't make sense)
    1. Pfsense hardware (acting as DHCP and DNS forwarder)

    Also network booting was set to boot\x64\ as well as the "next server" ip (that's WDS) under DHCP server -> Advanced options here is where I needed the dhcp options.

    that didn't work.
    Was still getting:

    "no response from windows deployment services server gateway"

    So I started googling :)

    while googling I was able to find this topic no' 38897 from a user called Snowspeeder:

    [Quoting Snowspeeder]
    [SOLVED]Point DHCP to WDS server
    « on: July 13, 2011, 08:27:18 am »
    This should be a simple solution but I can't get it to work.

    I have two subnets connected via IPSEC. 192.168.1.x and 192.168.2.x

    There is a WDS (windows deployment services) sever hosted at serving PXE clients.

    On the  192.168.2.X pfsense, under DHCP I have network boot options enabled pointing to and the file name Boot\x86\

    I can get pxe clients to boot on the 192.168.1.X network however those on the 192.168.2.X network cannot communicate with the WDS server.

    From an XP machine on the 192.168.2.x network, I can issue a "tftp -i GET Boot\x86\" and it will download the successfully, so I know it can transverse the VPN successfully.

    Any help would be appreciated.


    The issue was the file name. Here are the correct settings
    Filename: boot\x86\\000
    [END Quoting Snowspeeder]

    That was it, or at least part of it.  boot\x86\\000 and NOT boot\x64\ on the Default BIOS file name.

    Still didn't manage to get it work so I made some changes and found the solution here is how this worked for me:

    Under DHCP server -> Advanced options

    1. Next Server = Your WDS server IP

    2. Default BIOS file name = boot\x86\\000.

    3. Additional BOOTP/DHCP Option.

    4. Add one option

    Number  = 66

    Type = IP address or host

    Value = FQDM of your WDS

    5. Add another option

    Number  = 67

    Type = text

    Value = \boot\x64\\000

    That's it now it's working.

    Thank you PFsense for the fine design, you helped me run WDS without dhcp or dns from windows.
    I doubt if this is possible on another firewall.


Log in to reply