Losing webpage connectivity on VLAN



  • Hi,

    I have a home setup like this:

    Internet –- Netgate SG 2220 --- MikroTik --- workstations, untagged (LAN)
                                                                --- Intel NUC (proxmox), untagged, VLAN13, VLAN20
                                                                --- FreeNAS, untagged, VLAN13

    I'm using VLAN20 for some small webservers like dokuwiki, nextcloud, subsonic and I'm trying to use VLAN13 as a "management" interface for the NUC,  FreeNAS and MT (web configuration, ssh).

    When I'm accessing webpages (LAN to VLAN13) for proxmox, FreeNAS and Mikrotik, I lose connectivity after about 10 seconds and I have to refresh the page to be able to do anything. I don't see this problem with the other webservers and I didn't have this problem when they were on LAN.

    Some details:

    • pfsense updated to 2.3.3, no extra packages (snort, pfblocker)

    • pfsense is the DHCP, DNS, server. all routing is done here

    • rules between LAN and VLAN13 are allow all

    • mikrotik working as a switch only

    • tried with different switch

    • tried firefox and chrome

    • no alerts in the firewall

    • no abnormal CPU usage in pfsense or MikroTik

    • accessed FreeNAS from VLAN20, same behavior

    • SAMBA doesn't seem to have a problem cross-VLAN



  • Bump and an update:

    • I don't have problems over VPN, just over LAN

    • SSH also gets disconnected

    Any pointers are appreciated.