UPnP interfering with device that requires UPnP?



  • Hi,

    I have an HDHomerun Prime TV turner that is connected to a switch, which is connected to my pfsense box (it is not virtualized).  I was running it with UPnP enabled on WAN–>LAN and it was working fine.  I have a 4-port Intel Pro 1000 VT and wanted to set up the ports as a bridge, so I followed this guide https://www.infotechwerx.com/blog/Creating-a-Simple-pfSense-Bridge which seemed to work fine.

    The only problem was, DHCP wasn't assigning my tuner an IP address.  I rebooted the pfSense box and it started assigning it an IP again, but then the tuner software was complaining about UPnP being detected.  so I tried assigning the UPnP to WAN-->LAN (now bridge),  WAN-->OPT1,2,3 (all ports) and WAN-->OPT1 (the connector being used for the switch).  None of these worked.

    Paradoxically, I turned off the UPnP service and tried the tuner again and it started working (presumably) normally.  I am really stumped.

    Any ideas?