Installation on HP Proliant ML30 Gen9



  • Hi everyone, I have been using pfsense on a desktop machine and it is working well but now I need to upgrade it to a real server, so I bought an HP Proliant ML30 Gen9 server but I can't install pfsense on it.

    I have not been able to boot from installation CD on this server.

    I tried to boot directly from the CD (using UEFI) and nothing, I enter to intellgent provision on the hp server and select install OS, (the server just gives me the option to install a windows, redhat or centos family OS), I select any linux and nothing, I tried to boot from legacy and nothing.

    What am I doing wrong? or how can I install pfsense on this server??

    Thanks for yout help


  • Banned

    Which version? There's zero UEFI support unless you use 2.4 snapshots.



  • I am using version 2.3.2, where do I download 2.4?

    EDIT:

    I found 2.4 version but it is marked as experimental, I don't want to install experimental version because it is a production environment, is there a way to install 2.3.2 version on my server?


  • Banned

    Turn on legacy boot. If it's not possible, then no, there's no method.



  • @doktornotor:

    Turn on legacy boot. If it's not possible, then no, there's no method.

    I will try it in the night, thank you so much



  • well, there is no way to install pfsense 2.3 on this server, I installed pfsense 2.4 beta and it is working OK, thanks for your help



  • @oware:

    well, there is no way to install pfsense 2.3 on this server, I installed pfsense 2.4 beta and it is working OK, thanks for your help

    How you did it boot on UEFI? I have sucess installing 2.4 in UEFI mode but disk isn't listed in boot options after install.



  • Are you sure that you have properly set your Proliant UEFI options (ex. "any linux" is activated, even if it's not linux at all ) ? Do you have the same Proliant model and the latest UEFI BIOS is installed?


Log in to reply