Internet connectivity drops after using speedtest



  • Hello everyone,

    This is my first post and sadly it's a question…

    Few words about my setup.

    I have installed pfSense 2.2.6 in a 2008 R2 Hyper-V virtual machine in order to manage the 5 static (dynamically reserved*) IP's that my ISP provides through a single cable and witch are all of them on the same subnet. Since the ISP requires a MAC address for each IP, a virtual machine was required for this setup unless I would be able to purchase physical network cards.

    All of the provided IP's are using the same gateway since they belong to the same subnet. Therefore, for each WAN connection I was configuring, the system was creating a new gateway witch I have disabled them (except the first one) cause I had errors with the monitoring.
    I have managed to configure 1:1 NAT for some of my servers that require port 80 and to forward some ports into my lan.

    The speed of my connection is 100/100Mbit and I was able to test it via Speedtest when I had my old router in place without any issues.

    The problem.

    When I finished with my pfSense setup, I wanted to see how the internet speed was changed but alas, I have encountered an issue.
    Right in the moment where the tool was testing the upload, the internet connection got frozen (no other websites could be opened or access my webservers from the internet) and in the pfSense web-configurator I saw that the gateway was "offline".

    I have tried several things to restore it but the only thing that worked was a reboot of the pfSense system.

    As a last action, since I'm a new user in pfSense, I tried to un-monitor the gateway. This had the same result but after I had 1 successful test.

    The question

    Does anybody ever encountered an issue like this and how did you managed to resolve it?

      • Dynamically reserved. ISP provides static IP's in terms that they will never change as long as you have them listed in the IPS's setup page. The lease for each IP expires every 2 hours (info from the previous LinkSys router I had) but eventually I get the same IP after that for each MAC address I have assigned.


  • Any help or ideas?



  • as a new user of pfSense i'd advise you to upgrade to a supported version instead of running something out-of-date



  • I tried to, but versions 2.3.x are not supported in 2008 R2 Hyper-V.



  • @jcyr:

    Had the same issue under hyper-v, till I reduced the virtual disk size to 10gb. After that the 2.3 install went as expected.



  • The capacity of the virtual drive I use for pfSense is 5GB and honestly I don't see why I should use a larger capacity than what I have now.
    Therefore, the reason why I couldn't see the drive to install 2.3.x was not the capacity of the drive or the controller since I've tried all the resolutions I found in here.

    I suppose that the real question here is the unsupported version I'm using and not the issue I'm having even though sometimes issues are continued through versions until they are reported and fixed.

    Anyone can see that my setup is a bit of unique with 5 WAN connections over DHCP and I this is why I raised my question. Otherwise, no one else has an issue like this using a single or dual wan with real static IP's.
    What I will try though, is to disable all the other WAN ports and perform a speedtest having only 1 LAN and 1 WAN.


Log in to reply