Upgrade Problem Pfsense 2.3.3_1



  • Hi,

    Last night I tried to upgrade the pfsense software through WebUI 2.3.1_5 -> 2.3.3_1

    The upgrade shows successful and it rebooted. After it come online,  I am not able to access the router through WebUI (https)and SSH.

    We have restricted HTTP Configurator to listen on 443

    For WebUI on https it throws error
    Parse error: syntax error, unexpected end of file, expecting ']' in /usr/local/www/index.php on line 623

    May I know, how to rollback or fix it, looks like some bug in the software.

    Attached pfsense software upgrade log, for your reference.

    Model :SG-2440 pfsense

    I tried to connect via console and started SSH but its failing

    Enter an option: Mar 17 16:26:36 php-fpm[46144]: /sshd: The command '/usr/sbin/sshd' returned exit code '1', the output was 'Undefined symbol "compat13" referenced from COPY relocation in /usr/sbin/sshd'
    Mar 17 16:26:36 php-fpm[46144]: /sshd: New alert found: SSHD failed to start

    Could see the pfsense still on older version /etc/version

    2.3.1-RELEASE
    [pfsense upgrade log.txt](/public/imported_attachments/1/pfsense upgrade log.txt)



  • Similar Issue, upgraded, system stated it was rebooting, hour later still at hang state.  Internet good waiting now to force reset, getting may php errors.
    Logged in Via ssh and pressed 5 for reboot, router is pinging Im online but no console or http working.



  • @sat_cse28:

    For WebUI on https it throws error
    Parse error: syntax error, unexpected end of file, expecting ']' in /usr/local/www/index.php on line 623

    Strange.
    My "/usr/local/www/index.php" has only 550 lines (see also the source : https://github.com/pfsense/pfsense/blob/RELENG_2_3_3/src/usr/local/www/index.php )
    Consider exporting your setup, and re-install from scratch.



  • @Gertjan:

    @sat_cse28:

    For WebUI on https it throws error
    Parse error: syntax error, unexpected end of file, expecting ']' in /usr/local/www/index.php on line 623

    Strange.
    My "/usr/local/www/index.php" has only 550 lines (see also the source : https://github.com/pfsense/pfsense/blob/RELENG_2_3_3/src/usr/local/www/index.php )
    Consider exporting your setup, and re-install from scratch.

    I tried to factory reset from console but now not able to login with default credentials admin, pfsense. It says wrong password.

    on multi user mode its strucked at below step. Reset button is also not working.

    Starting webConfigurator…done.
    Configuring CRON...



  • @sat_cse28:

    I tried to factory reset from console but now not able to login with default credentials admin, pfsense. It says wrong password.

    99,9 %chance that your browser is caching the wrong password.
    Solution :

    1. Use another browser.
    2. Reset cache (password) -> hit Ctrl-F5

  • Banned

    Or use the anonymous mode in your browser



  • I am able to login with the password now on console but problem is after Reset to factory defaults

    Boot is strucked at

    Starting webConfigurator…done.
    Configuring CRON...

    WebUI still not working

    Parse error: syntax error, unexpected end of file, expecting ']' in /usr/local/www/index.php on line 623

    SSH not working

    Enter an option: Mar 17 18:59:51 php-fpm[289]: /sshd: The command '/usr/sbin/sshd' returned exit code '1', the output was 'Undefined symbol "compat13" referenced from COPY relocation in /usr/sbin/sshd'
    Mar 17 18:59:51 php-fpm[289]: /sshd: New alert found: SSHD failed to start.

    default version : pfSense 2.3.1-RELEASE-p1 ??


Log in to reply