VIPS == aliased IP?



  • hi all-

    just trying to straighten out my nomenclature here. I've got 3 static WAN IPs - I'd like to alias the remaining 2 to the WAN interface and use pf to redirect them to the appropriate internal servers. Is this something i can do in the web ui? I'm used to doing it in rc.conf/pf.

    thanks in advance,
    darren david



  • @darrendavid:

    hi all-

    just trying to straighten out my nomenclature here. I've got 3 static WAN IPs - I'd like to alias the remaining 2 to the WAN interface and use pf to redirect them to the appropriate internal servers. Is this something i can do in the web ui? I'm used to doing it in rc.conf/pf.

    thanks in advance,
    darren david

    Yes, use a proxy arp virtual address.  We don't at this time support interface aliases - that's coming (and works on code in HEAD), but won't make it for 1.0.

    –Bill



  • so i tried the proxy ARP, but i got no love until i physically went in to the shell and aliased the IPs with ifconfig. Am I doing something wrong?

    My WAN is configured as 1.2.3.4

    My aliased IPS are 1.2.3.5 and 1.2.3.6

    In Firewall > Virtual IPs for each virtual IP I configured:

    type: Proxy ARP
    interface: WAN
    ip addresses: single address 1.2.3.5 (or 1.2.3.6)

    i went into NAT and set up some port forwarding rules on the virtual IPs. however, nothing worked until i set up the aliases manually using ifconfig.

    any thoughts?

    thanks,
    darren



  • None.  Don't reboot else you'll be setting all that up again by hand.

    –Bill



  • You can try to set it up using CARP. However you will have some broadcasts that way from the CARP Interface but that shouldn't be a problem. CARP, like ProxyARP too, is another way to fake Layer2 Messages for your virtual IP.



  • I too also expierieced this same issues with the same resolution in 1.0-RC3. Is there a way to set aliases at boot time, maybe via /etc/rc.local (does this still work)? Or could we manually edit the config file somewhere. Thanks ahead.





  • i found that just adding a shell script call ifcfg.sh to /usr/local/etc/rc.d and setting chmod +x on it worked just fine to keep up the alias across reboots.
    my script looked as such

    #!/bin/sh
    ifconfig vr0 alias 192.168.1.20 netmask 255.255.255.255
    ifconfig vr0 alias 192.168.1.21 netmask 255.255.255.255

    hope this helps you, it worked for me.


Log in to reply