SOLVED - Can't make firewall/nat to work



  • Please feel free to move this post - I'm unsure if it belongs to nat or firewall.

    I have a pfsense with three interfaces;

    WAN (connected to internet)
    DMZ (webserver connected)
    LAN (just for administration for the pfsense box)

    I have set up the WAN interface with ipadress,subnetmask,gateway (x.x.x.254/28 x.x.x.241)
    The DMZ is set up with ipadress and subnet natmask (172.17.100.250/24)
    I have set up an virtual ipadress which is the same as the wan  interface (x.x.x.254/32 WAN other)
    I have set up a nat 1:1 with the wan adress and the dmz adress of the server (WAN x.x.x.254  172.17.100.22)
    And, I have added a firewall rule on the wan interface to the dmz ipadress of the server (* * 172.17.100.22 80 * none)
    (The above x.x.x correspond to a public ipadress I don't want to post on this forum).

    I have searched and I can't get this to work.
    Attached screenshots of the configuration of the above parts.
    What am I doing wrong?
    Thanks in advance!
    Regards


















  • using the same ip twice? (on wan & vip)



  • Thanks for the quick reply,

    Added a new external adress för WAN x.x.x.248
    The adress x.x.x.254 is the external address för the webserver

    From Pfsense I can ping from both DMZ & WAN to the internet.
    I can ping the server (172.17.100.22) from pfsense DMZ interface to the webserver.
    However, I can NOT ping 172.17.100.250 from the webserver to the DMZ interface.




  • Your pictures show no firewall rules on your "DMZ" interface to allow any traffic to be initiated from anything behind that interface. Therefore..



  • Added firewall settings to the DMZ.
    Added screenshots of the DMZ firewalll rule, network settings from the server, and the ping results.
    Still unable to access the servers website.








  • Bump


  • LAYER 8 Global Moderator

    Why would you think you could ping anything from DMZ when all you allowed in your rules was TCP.. "Ping" is ICMP not TCP..

    And your also only allowing it to talk to your wan IP??



  • Thanks everyone that helped with this.
    My setup was a Proxmox box with Pfsense installed as a virtual server and it turns out that the external interface either was misconfigured or faulty.
    So I set up another box without Proxmox and installed Pfsense and that worked fine.
    You guys rock! :)


Log in to reply