OpenTTD servers / Outbound NAT question



  • I recently added static IP addresses to my AT&T fiber internet. I have been able to set this up without too much trouble, I have several websites and such running on the different public IP addresses and forwarded the incoming NAT as needed.

    With OpenTTD I am running into problems. OpenTTD is a small open source transport management game for which you can run servers. The way it works is you start a server, the server advertises itself to a master server list on the OpenTTD website, so the OpenTTD client can then use that list for players to find servers. The problem I am running into is that my server advertises itself as the master IP of my connection, when I want it to be on a specific public IP address.

    So in short:

    PFSense has port 3970-3980 forwarded to internal 192.168.2.24 listening for connections on external address x.x.x.118
    OpenTTD starts up, advertises itself as being y.y.y.207, and the console gives an error that port 3979 is not open.

    I already figured out I am going to need Outbound NAT, and added the x.x.x.118 as an IP Alias virtual IP, but no matter how I configure the outbound NAT rule, I can't seem to get it to work.

    Do I need additional routing? Can someone explain how I would go about setting up the above scenario?

    For the record: I have a Pace 5286 gateway in front of my pfsense, which is configured as cascaded routing to my pfsense firewall.



  • I think I figured it out.

    1:1 Nat seems to be the best solution here….



  • Could you elaborate, I have a similar problem in which some users should surf (80,443) on a second external IP. But 1:1 Nat seems overkill for me here.

    edit: Hi my problem was defining a NAT Port that I shouldn't have done, now it works perfect:

    http://i.imgur.com/2W7rwyz.png

    62.X.X.X is my desired outbound IP that is defined as virtual IP -> IP alias for that one client and port.