SG-2440 Update to 2.3.3 bricked my unit



  • SG-2440 Update to 2.3.3 bricked my unit

    Good day Pfsense.  On Feb 20th I received the notice that 2.3.3 was released.  Last night I updated the firmware via the GUI from 2.3.2 and as always the gui showed the progress and went into the reboot screen.

    The issue is that the unit will not now boot and I have no idea what needs to be done to reset/fresh install the OS.  After sitting all night I unplugged the unit, waited 10 minutes and powered it back up -> still no boot.

    What is the next step?    2015/04/14  $574  SG-2440 w/Wireless

    Thank You



  • I (just) emailed support@netgate.com with the serial number.  Hopefully they can help!  Will update here how it goes.



  • I have to say that I am very disappointed in my decision to support PFSense with my 2015.04.15 order of the SG-2440 (with integrated Wifi)…. spending nearly $600 on an item that has failed to meet expectations from week 1.

    1 – after receiving the unit it was declared that the integrated (and costly) WiFi was essentially useless
    2 – a number of the upgrades have required jumping through a few hoops to allow the unit to boot.  Usually this would require coming onto this forum to see the SG-2440 unit upgrade issue forum posts and following the current headaches to solution.  Because of this, I have delayed each available upgrade for 1-2 months before jumping in.
    3 – the latest update to 2.3.3 hard bricked the unit… and given that the device is less than 2 years old is outside the support of the vendor.  For hardware that is still sold by the vendor, it is unacceptable for so many software upgrade bugs to exist… and it is unacceptable to require a client to drop another $100 to grab the current stock image.  See ‘A Full Re-Install was required’ below.

    While waiting for a solution to this latest Update failure on the SG-2440 I purchased a Netgear R7800 and flashed the unit with KONG’s DD-WRT build.  My prior 2 routers (1  DD-WRT, 1 Tomato) never had the upgrade pains that this SG-2440 unit has had… and the R7800 is significantly faster and more stable in both Wired & Wireless access  for 1/3 the cost of the PFSense SG-2440 appliance.


    A full re-install was required
    1 - https://www.netgate.com/docs/sg-2440/reinstall-pfsense.html
    2 – of course, given that the unit is older than 1 year I either need to pay $99 for the SG-2440 image file via support… or grab the Netgate ADI from https://www.pfsense.org/download/ and hope that I can tweak the system back to the factory installed options.
    3 – After downloading and using 7zip to un-compress the img file from above you need to use RUFUS to DD install to a USB card as per: https://www.netgate.com/docs/reference/create-flash-media.html
    4 – While powered on, insert the USB into the top slot, use Putty to come in as per https://forum.pfsense.org/index.php?topic=93252.0 (I was on serial, com 3, 115200)… and when the all black screen comes up press ‘enter’ to begin displaying data.  Now, keep putty open, and hard power reboot the device to begin the fresh install.  The short is that you need the VCP driver from http://www.silabs.com/products/development-tools/software/usb-to-uart-bridge-vcp-drivers in order to talk across the USB to Mini USB cable.


    I do not know if I will sell this device or trash it, however It is now clean flashed with the latest and greatest




  • 1 clarification. 
    I am glad to have contributed to PF Sense and have been happy with the capabilities of the project.
    I am NOT happy that my mode of contribution was on a frustratingly unstable device.



  • I understand your frustration, but:
    First thing i did after receiving my unit (4860 1U) was:

    • Go pfSense Gold

    • download factory images and back it up just to be able fix device in cause of my own actions, firmware bugs, SSD wearout.

    Good Attitude: before upgrade: full os backup , separate config backup.

    pfSense Gold access for 99 Bucks/year is not big amount of money especially when you wish to have access to latest docs (the pfSense Book), hangouts (from time to time there is something worth attention), and have additional backup channel for your config.

    BTW. next time when you will brick your device… call forum for help, probably some gold team member will share with you install image ;P

    Cheers.



  • As mentioned above. It is always best practice to backup your config before updating!

    Now all that aside.

    You said "not booting" what is it displaying during the boot cycle? Can you connect directly to a display interface and see what it is doing via a monitor?

    I saw another post by you that included a screenshot. Is that what is being shown once device has booted? Right away I see WAN is not configured anymore but LAN is active. In that state you should be able to access GUI locally. However, if that is not working, have you tried to reset the interfaces or reassign them? Reset the modem to reobtain a WAN?

    I'm also a little confused on why you would need to spend another $100 dollars for a stock image? Couldn't you just redownload PFSense directly from PFSense website and reinstall using a USB thumb drive for free? or is there something I'm missing here? Does this unit require some vendor drivers etc….? If you are talking about reobtaining backup image from PFSense Gold, well its only $100, they is very cheap compared to other services out there in the real world. However, couldn't you just do a factory reset on your unit? Have you tried a factory reset within PFSense GUI or via the physical button on the device?

    We need a little more information in order to properly help.


Log in to reply