2 link same subnet with failover



  • Good evening!
    I'm new to pfsense, mine is the following, I need to do this structure below:

    I have two dedicated links that access another company, they gave me these two dedicated links, I know it's strange but the two links are from the same network, my mission is to connect my lan on these two links failover, I could not do it on Pfsense gives the error:

    IPv4 address 192.168.10.230/22 is being used by or overlaps with: OPT1 (192.168.10.221/22)

    But in cisco it works, I'm going to change from Cisco to Pfsense in cisco the config are:

    Building configuration…

    Current configuration : 3837 bytes
    !
    ! Last configuration change at 10:21:53 UTC Tue Mar 7 2017
    ! NVRAM config last updated at 20:09:58 UTC Mon Mar 6 2017
    !
    version 15.0
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname ROUTER1
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    !
    no ipv6 cef
    ip source-route
    ip cef
    !
    !
    !
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    license udi pid CISCO2911XX sn XXXXXX
    !
    !
    !
    !
    !
    !
    !
    !
    interface GigabitEthernet0/0
    description (SITE1-A)
    bandwidth 30000
    ip address 192.168.10.230 255.255.255.252
    ip nat outside
    ip virtual-reassembly
    load-interval 30
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/1
    description LAN Local
    ip address 192.168.20.200 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    load-interval 30
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/2
    description (SITE1-B)
    bandwidth 30000
    ip address 192.168.10.231 255.255.255.252
    ip nat outside
    ip virtual-reassembly
    load-interval 30
    duplex auto
    speed auto
    !
    ip forward-protocol nd
    !
    no ip http server
    no ip http secure-server
    !
    ip nat pool MYPOOL 192.168.20.200 192.168.20.200 prefix-length 30
    ip route 10.10.54.0 255.255.255.0 GigabitEthernet0/0 192.168.10.229
    ip route 10.10.54.0 255.255.255.0 GigabitEthernet0/2 192.168.10.233 10

    !
    !
    !
    !
    control-plane
    !
    !

    scheduler allocate 20000 1000
    end

    1-) What should I use to make both Gateways work
    2-) I need them to fail over
    3-) I'm going to make a static route on my LAN to go through one of the two failover gateways