Dynamic DNS not working anymore



  • Since I updated pfSense to 2.3.3 my Dynamic DNS has stopped working. I get the following errors in the system log:
    
    [coide]
    Mar 29 17:48:29 	php-fpm 	92989 	/services_dyndns_edit.php: phpDynDNS (mail.domain.com): PAYLOAD: ILLEGAL Record of type 'AAAA' already exists for the specified hostname
    Mar 29 17:48:29 	php-fpm 	92989 	/services_dyndns_edit.php: phpDynDNS (mail.domain.com): (Unknown Response) 
    
    

    I've tried deleting the Dynamic DNS entries in pfSense and recreated them but this hasn't helped.

    Is there anything I can try to troubleshoot this? Up until this update was installed Dynamic DNS worked perfectly for me.



  • Surely I can't be the only one experiencing this issue with Dynamic DNS?



  • I am… but not having the same issue apparently. Mine just isn't updating the public ip.

    Mar 31 14:36:55	check_reload_status		Syncing firewall
    Mar 31 14:36:55	php-fpm	68522	/services_dyndns_edit.php: Dynamic DNS: updatedns() starting
    Mar 31 14:36:55	php-fpm	68522	/services_dyndns_edit.php: Dynamic DNS (blah.tk): running get_failover_interface for wan. found bge0
    Mar 31 14:36:55	php-fpm	68522	/services_dyndns_edit.php: Dynamic DNS (blah.tk) There was an error trying to determine the public IP for interface - wan (bge0 ).
    


  • I am also, but a different issue. Mine stopped working 2/19/2017 apparently. Route53 error in the SystemLog.

    I never changed the settings so I'll have to dig through the script and track it down.



  • I have a problem with DynDNS not updating public IP in sometimes look @ https://forum.pfsense.org/index.php?topic=130322.0



  • checkip.dyndns.com is/can be problematic
    https://redmine.pfsense.org/issues/6493

    Use a different checkip service if you have access to one.  Or create your own checkip service if you have someplace to host it.

    For custom checkip service details see the info section at
    Services / Dynamic DNS / Check IP Services



  • HI,

    thanks for you hint; but my question is…Why after first fail (a fail after a connection lost can be likely) DYNDns doesnt' retry to get the IP again after some minutes? And then, when i force it, it always and immediately takes the IP?

    Thanks in advance

    Alessandro



  • mine not working too after update



  • I had the same issue for awhile and ended up giving up on trying to fix it.

    I went ahead and changed over to no-ip.com using DNS Hosting with Dynamic IP Sync tools.

    It's been working fine ever since.

    Just something to think about if you get fed up with trying to get this to work.



  • +1, I am also having the same issue where its not updating my public IP.



  • Just to close the loop on my issue with Dynamic DNS, I found that some AWS services, Route53 being one of them, use a global scope for the region under the ZoneID. Which unfortunately is not the region I primarily deal with and had configured in pfSense.

    Once I updated the region in the ZoneID to us-east-1, the DDNS updated properly to R53 without errors.



  • @tortue:

    Just to close the loop on my issue with Dynamic DNS, I found that some AWS services, Route53 being one of them, use a global scope for the region under the ZoneID. Which unfortunately is not the region I primarily deal with and had configured in pfSense.

    Once I updated the region in the ZoneID to us-east-1, the DDNS updated properly to R53 without errors.

    I was also getting the Route53 but now it is working. Thanks man


Log in to reply