No such file or directory



  • this is why?

    Installing pfSense-pkg-OpenBGPD…
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up-to-date.
    Updating pfSense repository catalogue...
    pfSense repository is up-to-date.
    All repositories are up-to-date.
    Checking integrity... done (0 conflicting)
    The following 2 package(s) will be affected (of 0 checked):

    New packages to be INSTALLED:
    pfSense-pkg-OpenBGPD: 0.11_9 [pfSense]
    openbgpd: 5.2.20121209_2 [pfSense]

    Number of packages to be installed: 2
    [1/2] Installing openbgpd-5.2.20121209_2…
    ===> Creating groups.
    Using existing group '_bgpd'.
    ===> Creating users
    Creating user '_bgpd' with uid '130'.
    pwd_mkdb: /etc/master.passwd: No such file or directory
    pw: passwd file update: No error: 0
    pkg: PRE-INSTALL script failed
    Failed


  • Banned

    Well, if you are really missing  /etc/master.passwd you'd better reinstall the box from scratch.



  • I download install packege check file, I have no find missing which file. :'(






  • I have upgrade to PF2.4. but it still wrong.

    Installing pfSense-pkg-Quagga_OSPF…
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up-to-date.
    Updating pfSense repository catalogue...
    pfSense repository is up-to-date.
    All repositories are up-to-date.
    The following 2 package(s) will be affected (of 0 checked):

    New packages to be INSTALLED:
    pfSense-pkg-Quagga_OSPF: 0.6.17 [pfSense]
    quagga: 1.1.0_2 [pfSense]

    Number of packages to be installed: 2

    The process will require 7 MiB more space.
    1 MiB to be downloaded.
    Fetching pfSense-pkg-Quagga_OSPF-0.6.17.txz: .. done
    Fetching quagga-1.1.0_2.txz: …....... done
    Checking integrity... done (0 conflicting)
    [1/2] Installing quagga-1.1.0_2…
    ===> Creating groups.
    Using existing group 'quagga'.
    ===> Creating users
    Creating user 'quagga' with uid '101'.
    pwd_mkdb: /etc/master.passwd: No such file or directory
    pw: passwd file update: No error: 0
    pkg: PRE-INSTALL script failed
    Failed


  • Banned

    No idea what are the screenshots supposed to illustrate. Upgrading a broken install is just a nice waste of time. Do a CLEAN install.


  • LAYER 8 Global Moderator

    I had sim issue with the cron package when I upgraded to 2.4 beta this morning it was saying missing file.  A delete of the cron package and then reinstall worked.


  • Banned

    @johnpoz:

    I had sim issue with the cron package when I upgraded to 2.4 beta this morning it was saying missing file.  A delete of the cron package and then reinstall worked.

    If you mean this:

    than that's a different kind of pkg idiocy.


  • LAYER 8 Global Moderator

    Yup hit right on the head dok..  Your post in that redmine

    "Fail to rename /usr/local/www/packages/cron/.cron.php.tJJigfijGw23 -> /usr/local/www/packages/cron/cron.php: No such file or directory"

    Was exactly what I saw with cron.. other than it was different gibberish on the end, etc.

    I had keyed in the no such file or directory in the error and thought it was sim.. But has the OP deleted and tried a clean install? It doesn't look like a clean install of the package to me in what he posted but something going on with an update.



  • I dont know which files is missing now.  if your tell me files name, i can upload its.  :(


  • LAYER 8 Global Moderator

    "/etc/master.passwd: No such file or directory"

    This sure looks like its telling you /etc/master.passwd is missing..

    As dok was pointing out if etc/master.passwd was actually missing you would have bigger fish to fry then install of some package.

    [2.4.0-BETA][root@pfsense.local.lan]/root: ls /etc/mast*
    /etc/master.passwd    /etc/master.passwd.db


  • Banned

    @johnpoz:

    As dok was pointing out if etc/master.passwd was actually missing you would have bigger fish to fry then install of some package.

    More like a Moby-Dick. Mystery sorted out - some "improved" install image with /etc on ramdisk.  ::) ::) ::)



  • i am install in USB SD, where can download NanoBSD (embedded) Images v2.4 file ?!!  I am new re-install.


  • Rebel Alliance Developer Netgate

    There is no NanoBSD for 2.4. Use a serial memstick and perform a full install.



  • @jimp:

    There is no NanoBSD for 2.4. Use a serial memstick and perform a full install.

    v2.4 will has no NanoBSD?  i have no used serial, it is need what


Log in to reply