Problem with Captive Portal in CARP cluster?



  • Ok, I'm using the 2008-10-13 snapshot for 1.2.1 in a two machine CARP cluster and have run into the following issues:

    1. My master CARP machine doesnt seem to push any captive portal settings to the standby CARP machine
    2. I've uploaded files I used in a pfSense 1.2 system for a redirect to a PHP login page and I can see the index.htm page I uploaded works, however when it redirects to the page I have uploaded to the pfSense box I get a 404 Not Found error. I have checked the filename spelling and path in the HTML login page and they are the following:

    The code for my login page is:

    
    <title>LocationConnect CP Redirect</title>
    
    Loading...
    
    

    The login page redirects/reload to "http://10.0.0.1:8000/captiveportal-lclogin.php"

    Looking at the system logs on the master pfSense system I see nothing in the logs to suggest what I am doing wrong. Any suggestions or hints? Thanks!



  • I'd like to add that both machines are running off of cdroms at the moment. I tried dropping to shell on the master CARP box and tried to find the directory where the captiveportal files were supposedly being stored. I looked in /usr/local/captiveportal and didnt see any of my files there. I also looked in /tmp/captiveportal and didnt find anything there either. Looking at /var/etc/lightly-CaptivePortal.conf it looks like the captive portal should be dumping any errors into /var/log/lighttpd.error.log but I dont see that reflected as none of the 404 errors are showing up in that log file.

    So if anyone has any suggestions or help I would love to hear it. Thanks!



  • Ok, I can report back that when running pfSense 1.2.1 in cdrom mode, the captive portal doesnt seem to be able to find the files one uploaded via the CP upload interface. HTML loaded via the main CP config page does work however.

    I have since installed the pfSense onto the machines in the CARP cluster onto their hard drives with success. However, it would appear that now the captive portal is half broken. Basically, if I turn on the captive portal and try to connect to a webpage through the pfSense CARP cluster I never get redirected to http://10.0.0.1:8000/ for login. If I go into the captive portal setup and click on the link that takes me to the CP login the page loads and I can authenticate my MAC address via a username & password setup in a FreeRADIUS server running on the pfSense box.

    So in summary, HTTP redirect to CP login is NOT WORKING. CP login page will load if you go to its URL directly, and logins do get processed then.

    I have also run into other issues with CP + FreeRadius that I will detail in another post since they are separate from this issue I believe.


Log in to reply