[SOLVED] Quad Core Only Showing Single Core After Supermicro BIOS Upgrade



  • I bought the Supermicro X10SLM+-LN4F motherboard in 2013 and just haven't kept the BIOS and BMC/IPMI firmware up-to-date at all, which goes against my security practices of keeping that updated.  Got around to it a couple days ago.  Upgraded BIOS from 1.1 (7/19/2013) to 3.0a (12/17/2015), which is the latest on their website.  Upgrade went smoothly and successfully.  (Although I really wish their website was better.  They don't show release notes in the BIOS download page showing all the fixes.  So not very transparent at all.)

    I have a quad-core Xeon E3-1220 v3 @ 3.10GHz (Haswell), but ever since the BIOS upgrade, it only shows as having one core in the BIOS.  And thus, the OS downstream (pfSense on FreeBSD) also sees just one CPU core.

    This is very weird.  One would think that activating all CPU cores would be automatic.  What setting do I need to tweak in the BIOS to get it to recognize all four cores?


  • Netgate Administrator

    You might need to reset to default values after updating. It might be using the wrong memory location (or a different one at least) to look for that. Though that mostly automatic these days.

    Nothing much to be done in pfSense to help there though. All down to the bios settings.

    Steve



  • Thanks for the reply.  It's definitely not a pfSense issue and something on the BIOS/CMOS/motherboard.  I hope that once I find a solution that this helps others here who use Supermicro motherboards in their builds.

    I took another look at the [poor] instructions.

    ================================================
    FOR <filename>.zip

    1. Save this file to your computer.

    2. extract the files to a DOS bootable device (such as a bootable USB stick, or CD).

    2. Boot to a DOS prompt and type AMI.BAT BIOSname.###.

    4. Do not interrupt the process until the flashing is complete.

    5. After you see the message of BIOS has completed the update, unplug the AC, clear the CMOS and plug in the AC and power on the system.

    6. Go to the BIOS setup screen and press F9 to load the default and press F10 to save and exit.</filename>

    All I did in Step 5 was power down and unplug the AC.  I never bothered with clearing the CMOS, and I also never bothered with Step 6, loading the default settings again.

    The manual shows:

    Clear CMOS (JBT1)
    JBT1 is used to clear the saved system setup configuration stored in the CMOS
    chip. To clear the contents of the CMOS, completely shut down the system, remove
    the AC power cord and then short JBT1 with a jumper. Remove the jumper before
    powering on the system again. This will erase all user settings and revert everything
    to their factory-set defaults.

    This is very unlike all the IBM, Dell, HP, and Lenovo systems I've upgraded and not very user friendly to wipe out the CMOS and configuration.

    I'll open the case up and clear the CMOS jumper and also reload the BIOS defaults and report back.  I hope that's the solution instead of having to contact them to obtain an older BIOS image!

    I like the company still, but this is 1980's procedure.  :)


  • Netgate Administrator

    You should be able to just reload the defaults like it says without opening the case. If they changed the layout of the CMOS data at all between bios versions then that is normally required. Though, yeah, the BIOS update program would often so that for you.
    Let us know if that corrects it.

    Steve



  • Opened case and shorted the jumper with a screwdriver.  Didn't appear to reset the CMOS.  Powered down and instead removed the CR2032 cell for a few minutes, which did the trick.

    BIOS still showed 1 core.  But in another setting, "Active Processor Cores," it still gives me the choice of "All, 1, 2, 3" which means it still somewhat sees 4 cores.

    The BIOS instructions are wrong.  There is no F9 to load defaults or F10 to save and exit – they're different function keys.

    Bottom line, I don't know what to do and web searches are pretty fruitless, so I'll contact Supermicro support ASAP and get an answer.  This is complete BS and poor service from a company I respected.

    Surely others here who use Supermicro motherboards have experienced this...

    pfSense still no longer shows "1 package, 4 cores" like it used to.


  • Netgate Administrator

    Hmm, disappointing.

    I assume it's set to 'all' cores already? Might be worth setting it to something else, 2 say, an testing that then setting back to all.

    Steve



  • Summary:  Success!  Back to normal.  BIOS shows 4 cores, and pfSense shows "4 CPUs: 1 package(s) x 4 core(s)".

    Details:

    @Supermicro:

    Thank you for contacting Supermicro Computer's Technical Support.
    Could you please kindly to try to reflash the BIOS by using a DOS-bootable USB again by using the below method?

    Try the following to update ME in BIOS.
    a) Power down, set JPME2 jumper to pin 2-3, power up then flash BIOS. Please make sure the BIOS has been reinstalled completely.
    b) Power down, set JPME2 jumper to pin 1-2 after flashing BIOS

    Then, please kindly try to power down and clear CMOS to see if any changes.
    For clear CMOS, please following the instructions below:
    1. Remove AC power
    2.  Remove onboard CMOS battery and wait for 15~20 minutes
    3.  Place the battery back in
    4. Connect the AC

    If still failed, please kindly provide me the screenshot below:
    1. a screenshot of the Intel Server Platform Services page in the BIOS. You can refer to the user manual chapter 4 on how to find it. If BIOS ME is updated successfully, you should see ME FW status and SPS version updated in BIOS under Intel Platform Server Services. There will be more Active cores enabled in BIOS as well.

    Before I followed the instructions above, I took a photo of the "Intel Platform Server Services" screen in BIOS.  It said it was in Recovery mode (hint hint something's wrong).

    So I changed the JPME2 jumper and re-flashed BIOS, changed the JPME2 jumper back to default pins 1-2 and also removed CMOS battery.  After powering back up, everything was normal.  Intel Platform Server Services screen showed normal/upgraded status.

    Possible Root Causes
    1.  User error.  It's possible when I originally flashed the BIOS, there was a "SUCCESS!!" message on the screen, and I possibly powered down the system prematurely.  One has to wait several more minutes after the first "SUCCESS!!" message, and then several more "SUCCESS!!" messages will appear, and you will be returned to the C:\ prompt.  Then it's safe to power down.

    2.  JPME2 jumper was set to default pins 1-2 during BIOS upgrade, not allowing it to recognize the CPU?

    Either way, glad that mess is over and glad I didn't brick my motherboard.  Hope this helps anyone else with Supermicro motherboards.