Pfsense 2.3.3 + ldap AD - Autentica normal mas depois falha



  • Olá amigos,

    Estou tendo um problema que está me comendo o juízo. Estou trocando um proxy TMG pelo Pfsense em uma rede stub, ou seja, uma vlan para users, AD, DNS e DHCP tendo o TMG como default gateway com o cabo do modem conectado à ele.

    Em paralelo instalei e configurei o Pfsense integrado ao AD. Criei usuários de homologação em cada grupo (+- 8 grupos) com suas respectivas Group ACL's.Efetuei os testes com cada usuário de homologação com suas respectivas policy (que vão desde acesso full até deny total) e rolou de boa.

    Quando fui migrar os usuários os primeiros foram de boa, sem novidade (tudo acompanhado pelo log real time)… mas quando cheguei no sétimo usuário (+- 10 minutos), os browsers dos usuários migrados começaram a mostrar o pop-up de usuário e senha, como se o mesmo tivesse fechado o browser. À partir daí as autenticações passaram a dar time out (no log real time não mais aparece o usuário na ultima coluna).

    Pela console executei o comando:

    /usr/local/libexec/squid/basic_ldap_auth -R -b "dc=dominio,dc=com,dc=br" -D "cn=pfsense,cn=Users,dc=dominio,dc=com,dc=br" -w "pfsense" -f sAMAccountName=%s -h 10.10.10.10

    Colocando depois usuário senha retorna ERR success.

    Fiz restart dos processos e até do Pfsense mas o cenário permaneceu o mesmo.

    Se alguém puder dar uma luz aí eu agradeço de antemão!

    Dados do ambiente:

    Win 2008 Enterprise R2 - AD
    Core i5, 1tb, 8Gb ram - Pfsense 2.3.3 AMD64

    Abraço!



  • Os helpers do squid costumam responder com ERR ou OK user=xxxxx

    Consegue repetir esses testes do helper via console para ver se ele está respondendo bem em sucessivas tentativas?



  • Olá Marcelo,

    Estava retornando OK e logo em seguida passou a retornar ERR success.

    Grato



  • Uma luz alguém?



  • Monitora com o tcpdump e executa o helper na  mão. Veja se consegue identificar o que vem de errado ou se aparece alguma coisa no system logs.


Log in to reply