[Solved] WAN Interface stopped working after install additional NIC



  • Hi PFSense community,

    yesterday i installed new NIC Interface (Opt1) , after installing the WAN Interface stopped working the only interface working is the Built-in Interface (LAN). can anyone help me what to do to make it work.

    thanks in advance.



  • I tried to uninstall the NIC Card and the my PFSense back to working condition.


  • Banned

    You need to reassign the interfaces when you install or swap NICs.

    You can do this via the console, or the webgui if you didn't change the LAN NIC. But in all cases you can do it via the console. pfSense will prompt you for it on boot and will help you assign interfaces as necessary.

    Just plug in a monitor and keyboard, reinstall the NIC and reboot following the prompts and it will work for you unless it is some hardware defect.


  • Netgate Administrator

    Yes likely what happened was the new card is using the same driver as the existing WAN NIC and happened to be detected first during bootup.

    That would have the effect of renumbering the NICs such that the new NIC became the WAN and the NIC that was previously the WAN became the spare interface.

    Re-assigning the NICs from the console could switch the order back if required or simply swap the cables.

    Steve



  • thank you for your response pfBasic & stephenw10, I will try it later cause the firewall is currently active, but i will write down mac addresses of my current interfaces to check if there is renumbering of NICs when i try to add the new NIC.

    again thanks


Log in to reply