SRVR Fail - DNS Zone (bind)



  • So I have the Bind package installed.

    I am trying to setup "split dns" where I have some "unofficial" authoritative zones setup for domains I want to route differently inside.

    Specifically, I have a virtual server and load balancing setup for a web site I'm hosting internally, but I cannot seem to configure the virtual server to recieve connections from inside my network, so I've tried to setup a simple DNS RR, which works for one domain, lets call it example1.com.  but after setting that up, I've tried to do example1.site, with the same zone configuration parameters, and with any query against it (Nslookup; set type=any; example1.site)  I get a "Server Failed".  No error is logged to the bind log under resolver.    I turned on "insane" everything logging, and all I see in the log file is:

    client @0x803069e00 192.168.1.178#65033 (example1.site): view LAN View: query failed (SERVFAIL) for example1.site/IN/ANY at query.c:6905

    I've created some other .site domains, and it works fine.  I've created about 5 other domains, and they all work.  Any idea how to get this working?

    I have tried to remove the zone from the configuration, and reconfigure.  I have removed the zone, gone to the filesystem, and deleted the DB file, and reconfigure through gui, and that doesn't work either.

    I'm kinda stuck.

    Any troubleshooting steps would be appreciated.

    Thanks in advance!

    Guess I should say:
    pfSense 2.3.3-RELEASE-p1 (amd64)
    BIND 9.11.0-P3

    DNS Resolver, and DNS Forwarder are off.


  • Banned

    Post the zone file; noone can debug otherwise.



  • Sorry to let this go for so long… the cause was due to DHCP server trying to register the clients in the zone, and it was locking up the .jnl file.  Restarting BIND after deleting the .jnl file was the solution (and turning off the attempt to auto-register things in DNS>