Mirror disk followed by mount error 19



  • Hi,

    I tried to mirror a pfSense disk but something went wrong.
    And now the original disk won't boot anymore.

    The error is:
    GEOM_MIRROR: Force device pfSenseMirror start due to timeout.
    GEOM_MIRROR: integrity check failed (mirror/pfSenseMirror, MBR)
    Mounting from ufs:/dev/ufsid/ <a long="" id="">failed with error 19.

    Then I'm dropped a the mountroot prompt.

    mountroot> ?
    List of GEOM manged disk devices:

    mirror/pfSenseMirror ada0

    Now, is there a way to check whether the disk still has the pfSense installation files?
    And I will just have to fix the bootloader?




    </a>


  • Netgate Administrator

    Hmm, what did you do to create the mirror? Did it appear to succeed?

    Try running at the mountroot> prompt:

    ufs:/dev/ada0s1a
    

    It could be just the geom label that's missing.

    Steve



  • ufs:/dev/ada0s1a would return
    
    Mounting from ufs:/dev/ada0s1a failed with error 19.
    
    

    What I'm trying to avoid is a fresh install.
    But I have the config.xml backed-up so I think I'll go that way.

    The story is that I booted the pfSense usb media, selected Setup GEOM Mirror.
    The it appeared that the mirror operation went well.
    However after reboot, I got the error.


  • Rebel Alliance Developer Netgate

    It only shows one disk in that output. Maybe one of your disks failed?

    Though it should still boot from the remaining disk, perhaps it also has an issue.

    A reinstall here would be safer than trying to recover. Replacing the disk(s) and reinstalling would be safest.



  • Ran into the same error when trying to install pfSense (current version 2.3.4) to a new embedded appliance (IBOX-501 N10/Protectli type device) with SSD or CF from a USB or CDROM. Cause of the issue is related to GPT (GUID Patition Table) marked media, and can affect either the new SSD, CF and/or the USB install media. Using Windows, this is how I was able to correct the issue.

    Using Windows 7 PC with administrative rights

    • Connect SSD or CF media to the Windows PC
    • Open a command prompt (with admin rights)
    • Start the DISKPART utility by typing DISKPART
    • type LIST DISK and note the number of the drive that will contain the pfSense installation
    • type SELECT DISK (number)
    • type CLEAN and wait for the task to complete
    • type CONVERT MBR and wait for the task to complete
    • type EXIT
    • remove the SSD or CF drive

    Seems that some USB thumb drives are shipped from the factory with GPT instead of MBR. If installing pfSense from a USB drive use the same steps above to prepare the USB media. Seems SanDisk and some Corsair USB drives are shipped from the factory with GPT.

    After completion, a USB drive can be set up to install pfSense using Rufus.