Atheros AR5006X Wireless A/B/G Mini - auto channel breaks it

  • I am using the latest snapshot:
    built on Sat Oct 18 05:40:25 EDT 2008

    The latest snapshot if I set the channel option to "auto" it breaks it.  But if I pick a channel it works fine including channel 6 (turbo?).

    I get this error in the console if I set it to auto:  ath_chan_set: unable to reset channel 6 (2437 Mhz, flags 0x690 hal flags 0x150)

    I just installed this card via mini-PCI adapter last night and FreeBSD was able to identify it with no problems.  So not sure what is up.


  • paste the contents of /tmp/

  • #!/bin/sh

    pfSense wireless configuration script.

    enable shell debugging

    set -x
    /bin/ps awwuxx | grep hostapd | grep ath0 | awk '{ print $2 }' | xargs kill

    Enable ATH distance settings

    /sbin/ -i ath0 -d '2000'

    /sbin/ifconfig ath0 down
    /sbin/ifconfig ath0 mode '11g'
    /sbin/ifconfig ath0 channel '6'
    /sbin/ifconfig ath0 -mediaopt turbo
    /sbin/ifconfig ath0 ssid 'NetWorld'
    /sbin/ifconfig ath0 -hidessid
    /sbin/ifconfig ath0 -mediaopt adhoc
    /sbin/ifconfig ath0 protmode 'rtscts'
    /sbin/ifconfig ath0 -pureg
    /sbin/ifconfig ath0 -apbridge
    /sbin/ifconfig ath0 -wme
    /sbin/ifconfig ath0 authmode open wepmode off
    /sbin/ifconfig ath0 txpower '30'
    /sbin/ifconfig ath0 mediaopt hostap
    /sbin/ifconfig ath0 mtu 1500
    /sbin/ifconfig ath0 up
    /usr/sbin/hostapd -B /var/etc/hostapd_ath0.conf

  • That's with it set to channel 6, what's it show when it's set to auto?  then manually run it, what does that show?

  • If I set it to auto I get that error when it tries to switch to channel 6 which I assume it would start off at channel 6 and then scan around for best clear channel.

    If I set it manually to channel 6 it works fine, just not in auto.

    I can also select other channels and it works fine.

    I have a feeling the auto is not reading the configuration information correctly which may work fine for other wi-fi cards while mine is a little picky with certain settings.

Log in to reply