Squid as transparent proxy with cache



  • Hi!

    I have pfsense 1.2-release
    1xLAN
    1xWAN
    1xWifi

    Wifi and LAN  are going to internet over WAN

    I have installed squid, squid content filter, and proxy report  packages..

    i want a transparent proxy for HTTP (so i don't need to configure every browser on every PC for every user that should use proxy)..  (and i have set cache to 30GB)

    So i go to squid general settings
    i have selected:

    • LAN, Wifi interfaces
    • transparent proxy checkbox
    • proxy port 8080
    • enabled logging into /var/squid/log

    after that i see in logs that i am not going through proxy..,

    if i enable: Allow users on interface
    then i can't open any HTTP page

    so i go to: Access control > Allowed subnets > and i wrote two subnets:  192.168.10.0/24 and 192.168.12.0/24    (these are my LAN and Wifi)

    but after save…, restart squid service.., i still can't open any page..., in logs, a have TCP_MISS ?

    after while i get page (60) Operation timed out.

    i see in access.log

    1224409049.711 180047 192.168.10.31 TCP_MISS/504 1498 GET http://forum.domeka.net/ - DIRECT/192.168.10.1 text/html

    (192.168.10.1 is my pfsense address)

    where is a problem ? what am i doing wrong ?



  • ok i found a problem..

    i had a other package.., "proxy content filter".., that I didn't configure…, default is to deny a page..., i did allow all pages., and now it works..



  • @hkusulja:

    ok i found a problem..

    i had a other package.., "proxy content filter".., that I didn't configure…, default is to deny a page..., i did allow all pages., and now it works..

    Hm.. While any package installing,  you can see message "check you package configurstion"  ::)


Log in to reply