Pfsense 2.3.3 Unable to check for updates



  • I have the problem to my pfsense 2.3.3, my pfsense is Unable to check for updates. and my package and my package is Unable to retrieve package information. in past few days it works but yesterday I noticed when I go to my package manager it said "Unable to retrieve package information" and when I go to my dashboard my pfsense does not retrieve the package information.

    I go to System >> update >> Update Settings

    Branch: stable(default)

    then hit save.

    but same error cant update

    here is the screenshots:







  • LAYER 8 Netgate

    Almost always because the firewall itself is unable to resolve DNS and/or access the internet.

    What are your DNS settings in System > General Setup??



  • I can access the internet but failed "Unable to check for updates"
    I have two dns 8.8.8.8 and 8.8.4.4


  • LAYER 8 Netgate

    There is a difference between being able to access the internet from inside the firewall and the FIREWALL ITSELF being able to access the internet.

    Can you resolve names in Diagnostics > DNS Lookup?



  • sorry but dont know what name or ip that resolve in Diagnostics > DNS Lookup?

    I also tried this command pkg update and pkg install pfSense-base here is the error

    "pkg: Repository pfSense-core load error: access repo file(/var/db/pkg/repo-pfSense-core.sqlite) failed: No such file or directory
    Fetching meta.txz: 100%    944 B  0.9kB/s    00:01
    Child process pid=40494 terminated abnormally: Segmentation fault"


  • LAYER 8 Netgate

    That looks pretty screwed up. If you can take a backup configuration in Diagnostics > Backup & Restore I would do so.

    You might want to try reinstalling fresh and restoring the configuration.



  • is there any command for update or restalling? thanks!


  • LAYER 8 Netgate



  • [2.3.3-RELEASE][root@wapbytez.quantumbyte.local]/root: pkg update -f
    Updating pfSense-core repository catalogue…
    pkg: Repository pfSense-core has a wrong packagesite, need to re-create database
    Fetching meta.txz: 100%    944 B  0.9kB/s    00:01
    Child process pid=73017 terminated abnormally: Segmentation fault

    does anyone have a "repo-pfSense-core.sqlite" for i386 pfsense 2.3.3? please can you upload it? thanks in advance!


  • Banned

    Why? Just delete the DB if you think it's corrupt.



  • @doktornotor, how do you get it to recreate the file if you delete it?



  • The file should exist :

    [2.3.4-RELEASE][admin@pfsense.brit-hotel-fumel.net]/root: ls -al /var/db/pkg/repo-pfSense-core.sqlite
    -rw-r--r--  1 root  wheel  212992 Jul 14 22:08 /var/db/pkg/repo-pfSense-core.sqlite
    

    and if it doesn't, it will be auto created by the "package system.

    Btw : check your drive.
    Check if the directory /var/db/pkg exists.
    Can you write something there ?
    Etc.


Log in to reply