DNS does not work if "default" interface is down



  • I have 3 WANs configured:

    They are all load balancing

    Unfortunately, once "default" interface is dowm, DNS doesn't work anymore. I can still access sites by IP, but DNS is not available.

    This is probably because of DNS forwarder, which is resolving DNS only via default interface.

    How to fix this?


  • LAYER 8 Global Moderator

    use the resolver and have it use 1 or all of the interfaces you would like it to be able to use..


  • Rebel Alliance Developer Netgate

    If you are using the forwarder, or the resolver in forwarding mode, go to System > General Setup, and setup one DNS server for each WAN. So the first DNS server would use the gateway for the first WAN, second with a gateway for the second WAN, and so on.

    If you are using the resolver in non-forwarding mode, then activate default gateway switching from System > Advanced, Misc.



  • How can I set DNS for each WAN? It should be set by DHCP. I just don't know which DNS is for which WAN!

    Of course, I know 8.8.8.8 and 8.8.4.4, but these are only 2, while I need 3.



  • I'm using the forwarder and have mine set up this way (I also have IPv6 set up) and was having the same problem until I added the last 2 entries.
    Under System/General Setup on the DNS server settings I have 6 entries.

    2001:4860:4860::8888  WAN_DHCP6  (google IPv6)
    2001:4860:4860::8844  WAN_DHCP6  (google IPv6)
    208.67.222.222  WAN1_DHCP  (openDNS)
    208.67.220.220  WAN1_DHCP  (openDNS)
    8.8.8.8    WAN2_DHCP  (Google)
    8.8.4.4    WAN2_DHCP  (Google)

    If I failover to WAN2 it will use those two google DNS servers, if I am running normally, it uses openDNS.

    Note, I don't know if I can have duplicate DNS server IPs with different interfaces. I've never tried.


Log in to reply