VLAN issue fixed for me in 1.2.1



  • I tried 1.2.1 about a month ago on hardware that was running 10 VLANs on a sis interface and it didn't load any of the VLAN interfaces so I rolled back to 1.2. I just tried the oct 20 release and it seems to be fixed.



  • Great, thanks for letting us know. The recent fix does seem to resolve the issues.



  • I should also note that 1.2.1 fixed issues I was having with vr hardware in 1.2.
    I was receiving vr0: rx packet lost errors and poor throughput. They have all gone away now and my throughput is back.  Must be the new version of freeBSD.
    Thanks



  • Confirmed! thanks - I think 1.2.1 is ready for RC2 now  :D



  • @cheesyboofs:

    Confirmed! thanks - I think 1.2.1 is ready for RC2 now  :D

    It hasn't been officially stamped as the RC1 release yet.  :)  Yes the builds have said as much for a while, but until there's a blog post, and the name of this forum changes, it's not officially RC1.

    Though as long as people have been using RC1-labeled snapshots it might make sense to call the first "official" release candidate RC2.



  • @blak111:

    I tried 1.2.1 about a month ago on hardware that was running 10 VLANs on a sis interface and it didn't load any of the VLAN interfaces so I rolled back to 1.2. I just tried the oct 20 release and it seems to be fixed.

    Hi blak111,

    I would just like to inquire what were the vlan ID's you used for the vlans. I'm having problems with my setup on an INTEL Server with 4 NICS. I setup pfsense to have 3 vlans on the LAN interface and used 10, 20 and 30 as vlan ID's. However, when I took a look at the interfaces via the command line with ifconfig, it tells me that I have vlan1, vlan2 and vlan3 as interfaces although I see that there are vlan id's 10, 20 and 30 in the details of the interface.

    Sicnarf



  • Hmm the first nic should be listed as vlan0
    If I do ifconfig I get
    vlan0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    –->Lines deleted by me<----
    vlan: 11 parent interface: em0

    I setup pfsense to have 3 vlans on the LAN interface and used 10, 20 and 30 as vlan ID's

    As you write this it can be wrongly interpreted. It's not called LAN interface but parent interface as a parent interface never should be assign.
    Setting up vlans in console</up,broadcast,running,simplex,multicast>



  • I'm more than convinced that vlan's are working, in fact I'm not using anything else  :P

    # ifconfig
    em0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            options=9b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum>ether 00:02:b3:d3:c2:62
            inet6 fe80::202:b3ff:fed3:c262%em0 prefixlen 64 scopeid 0x1
            media: Ethernet autoselect (1000baseTX <full-duplex>)
            status: active
    pflog0: flags=100 <promisc>metric 0 mtu 33204
    lo0: flags=8049 <up,loopback,running,multicast>metric 0 mtu 16384
            inet 127.0.0.1 netmask 0xff000000
            inet6 ::1 prefixlen 128
            inet6 fe80::1%lo0 prefixlen 64 scopeid 0x3
    enc0: flags=0<> metric 0 mtu 1536
    pfsync0: flags=41 <up,running>metric 0 mtu 1460
            pfsync: syncdev: lo0 syncpeer: 224.0.0.240 maxupd: 128
    vlan0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            options=3 <rxcsum,txcsum>ether 00:02:b3:d3:c2:62
            inet6 fe80::202:b3ff:fed3:c262%vlan0 prefixlen 64 scopeid 0x6
            inet 192.168.100.254 netmask 0xffffff00 broadcast 192.168.100.255
            media: Ethernet autoselect (1000baseTX <full-duplex>)
            status: active
            vlan: 77 parent interface: em0
    vlan1: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            options=3 <rxcsum,txcsum>ether 00:02:b3:d3:c2:62
            inet6 fe80::202:b3ff:fed3:c262%vlan1 prefixlen 64 scopeid 0x7
            inet xx.xx.xx.xx netmask 0xfffffc00 broadcast 255.255.255.255
            media: Ethernet autoselect (1000baseTX <full-duplex>)
            status: active
            vlan: 11 parent interface: em0
    vlan2: flags=8842 <broadcast,running,simplex,multicast>metric 0 mtu 1500
            options=3 <rxcsum,txcsum>ether 00:02:b3:d3:c2:62
            inet6 fe80::202:b3ff:fed3:c262%vlan2 prefixlen 64 scopeid 0x8
            media: Ethernet autoselect (1000baseTX <full-duplex>)
            status: active
            vlan: 22 parent interface: em0
    vlan3: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            options=3 <rxcsum,txcsum>ether 00:02:b3:d3:c2:62
            inet6 fe80::202:b3ff:fed3:c262%vlan3 prefixlen 64 scopeid 0x9
            inet 192.168.101.254 netmask 0xffffff00 broadcast 192.168.101.255
            media: Ethernet autoselect (1000baseTX <full-duplex>)
            status: active
            vlan: 33 parent interface: em0
    vlan4: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            options=3 <rxcsum,txcsum>ether 00:02:b3:d3:c2:62
            inet6 fe80::202:b3ff:fed3:c262%vlan4 prefixlen 64 scopeid 0xa
            inet 192.168.104.254 netmask 0xffffff00 broadcast 192.168.104.255
            media: Ethernet autoselect (1000baseTX <full-duplex>)
            status: active
            vlan: 44 parent interface: em0
    tun0: flags=8051 <up,pointopoint,running,multicast>metric 0 mtu 1500
            inet6 fe80::202:b3ff:fed3:c262%tun0 prefixlen 64 scopeid 0xb
            inet 192.168.102.1 --> 192.168.102.2 netmask 0xffffffff
            Opened by PID 474
    #</up,pointopoint,running,multicast></full-duplex></rxcsum,txcsum></up,broadcast,running,simplex,multicast></full-duplex></rxcsum,txcsum></up,broadcast,running,simplex,multicast></full-duplex></rxcsum,txcsum></broadcast,running,simplex,multicast></full-duplex></rxcsum,txcsum></up,broadcast,running,simplex,multicast></full-duplex></rxcsum,txcsum></up,broadcast,running,simplex,multicast></up,running></up,loopback,running,multicast></promisc></full-duplex></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum></up,broadcast,running,simplex,multicast>
    




  • @cheesyboofs:

    I'm more than convinced that vlan's are working, in fact I'm not using anything else  :P

    That map is serious food for thought. Thanks for posting it.



  • @Perry:

    Hmm the first nic should be listed as vlan0
    If I do ifconfig I get
    vlan0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    –->Lines deleted by me<----
    vlan: 11 parent interface: em0

    I setup pfsense to have 3 vlans on the LAN interface and used 10, 20 and 30 as vlan ID's

    As you write this it can be wrongly interpreted. It's not called LAN interface but parent interface as a parent interface never should be assign.
    Setting up vlans in console</up,broadcast,running,simplex,multicast>

    Hi Perry,

    Got it to work already. Turns out, I forgot to set the tagged port for each untagged port in the switch that I was using. It's all fine now from a vlan standpoint, and I'm having no problems with the vlans yet. I encountered an update problem with snort but this is for another topic. Thanks for the link by the way.

    sicnarf


Log in to reply