Virginmedia L2TP Tunnelling



  • Hello All,

    New to pfSense, I have installed it but I am having an issue with Virginmedia.  I am currently on their business package with a Superhub.  Unfortunately the hub does not have a modem only mode so I am currently getting a 192.X.X.X ip address for the WAN.  I have spoken to Virginmedia and have been advised only they can turn on modem only mode from their end.  They have also advised me that I will have to use "L2TP Tunnelling" to connect to Virginmedia.

    Can anyone please guide me on how this can be setup in pfSense….  Thanks



  • I have a similar setup. Do not worry worry about asking Virgin to make your superhub modem only. You can get PfSense working as it is, all you need to do is connect that router to your PfSense boxes WAN port and assign the interface as DHCP.

    Make sure you do get another wireless router behind PfSense, and turn off Wi-Fi on the superhub. So that your devices don't bypass PfSense altogether.



  • pfsensation….  Thank you will give it a try



  • I use VM as well, although not the business package and with SH3.

    If you do the above are you not double natting?

    I fix my wan IP on pf and then add that IP to the DMZ on the SH3


  • Netgate Administrator

    I'm not familiar with the VM Superhub3 but usually devices like that offer a 1:1NAT to a DMZ device which is better than nothing but still double NAT.

    Double NAT is usually not a problem though even if it is best avoided.

    pfSense can do an L2TP WAN. I'm not sure I've ever seen it used…

    Steve



  • Not on a business package here, but the superhubs should have a modem mode option in the GUI*
    Unless there is a difference between business and home user versions of the superhub, it should be there.

    both the original superhub v1, and our recent v3* had/have this
    **I am very glad for this, the hardware is nice but it's software is utter garbage (hard-coded LAN 192.168.0.x IP range and broken port forwarding)


Log in to reply