Watchguard Firebox x550e Core - Can't see BIOS via null modem cable?



  • Longtime lurker, first-time poster…

    I'm encountering an interesting problem with a Watchguard Firebox x550e Core. I verified that it was working with the stock firmware, was able to see the BIOS initially, and explored the settings before I flashed to B7 using FreeDOS via USB FTDI null modem cable from my Windows laptop @ 9600 8N1.

    However, when I try to watch the box POST or access the bios @ 115200 as described in various how-tos, I just see garbage characters (I also see these before the 3 beeps @ 9600, but then I can see the DOS prompt and execute commands with no issues). Same when trying from my Ubuntu machine (tried with screens, minicom, and putty), so I'm tempted to conclude that the cable is at least potentially OK but perhaps not properly configured.

    Does anyone have experience with this? Any and all tips appreciated, as I'm eager to move this project forward. I've tried off and on for about a week and I'm out of ideas.



  • Oh, I should add that this box was briefly up and running with pfSense nicely but I ran into a DMA issue after upgrading so I needed to start over.


  • Netgate Administrator

    Sounds like it isn't running at 115200. Or potentially your terminal settings are wrong.

    You should use the v0.81 BIOS if you can as that allows booting from a much wider range of devices:
    https://sites.google.com/site/pfsensefirebox/home/XEBIOS_81.BIN

    If you can still boot to the loader prompt in pfSense you can override the DMA settings and complete the boot, then add the settings permanently.
    https://doc.pfsense.org/index.php/Boot_Troubleshooting#pfSense_2.2_and_later

    Steve


Log in to reply