Lockups with Intel Gigabit VT Quad Port NIC



  • I just upgraded my pfsense box.  My last system was an older Intel Core 2 Duo system with an Intel Gigabit VT Quad Port Server NIC, but I purchased a new HP T730 thin client and transferred the Intel NIC into the T730s PCIe slot.

    Pfsense installed fine, but the system would lock up a minute or two after booting (would not respond to keyboard, ping, ssh, etc).  After some troubleshooting, I followed this steps outlined here: https://doc.pfsense.org/index.php/Tuning_and_Troubleshooting_Network_Cards

    After adding kern.ipc.nmbclusters="1000000" to /boot/loader.conf.local, the system now runs for 10 - 15 mins before locking up.  I then tried unplugging the NIC from the system and after leaving it on all night it was still stable in the morning.

    The NIC is completely stable in my old Core 2 system.  Thinking there might be some sort of hardware compatibility issue between the NIC and my new system, I installed both Windows 10 and Linux Mint onto the new box with the NIC installed.  The system however was stable and worked fine for several hours with both Windows 10 and Linux.  I redownloaded my Pfsense image and recreated the USB installer to see if by chance I got a bad installer, but the issue persists.

    Does any one have any ideas?


Log in to reply