2.3.4 Bricked my Netgate SG-4860\. Help!



  • I took the risk and updated to 2.3.4.  Now my Netgate/pfSense firewall won't boot.  If I console into the device at boot I can get to where it says press F12 for boot menu, and F1: PFSense.  Whenever I press F1 it immediately freezes with what I assume is a stuck spinner | .  Please advise!


  • Rebel Alliance Developer Netgate

    The serial speed is set right after that point, are you sure your console settings are correct? Try using a console speed of 9600, 38400, or 19200 and see if you get output on any of those.

    We tested the installation and upgrade process on the 4860 extensively, so I wouldn't expect there to be any issues caused by the update itself.



  • I also experienced this, where the spinner stops at the first vertical pipe, and there is no further garbage/junk text that would indicate a console speed difference, and the device never boots up (can't access web gui, etc.)

    My console speed for pre-boot was 115200. I've also changed it to 19200, 38400 and 9600bps – There, I see the 115200 data from pre-boot as random junk text, but never any clear text after the kernel starts to load.



  • I tried the different speeds and just got gibberish.  I am using 115200 as indicated in the documentation.  Here is a video  I just made showing my issue.

    Youtube Video

    Thanks for your help.



  • I downloaded the manual install files from the member portal and tried installing 2.3.3 and 2.3.4 and I get stuck on it too.

    It gets stuck here.
    https://postimg.org/image/xp23qw4bz/



  • With the help of the PFSense team I was able to get it working again by reflashing the software onto the device.  In case anyone else has this problem.



  • Do you have support incidents on your pfSense portal account? I was told I have to purchase support in order to get access to the factory firmware for the pfSense/Netgate branded devices.



  • Really i have the same issue un my WG x750e (https://forum.pfsense.org/index.php?topic=130150.0)
    After update from 2.3.3_1 to 2.3.4 - i have kernel panic and device doesn't boot.
    I try make clean install from downloaded pfSense-CE-memstick-serial-2.3.4-RELEASE-i386.img
    but results - the same.
    So, i install 2.3.3 at the moment and don't do update.
    Some one resolve this trouble or find any info?



  • @klave7:

    With the help of the PFSense team I was able to get it working again by reflashing the software onto the device.  In case anyone else has this problem.

    Hi
    Where did you download the firmware image file from? I have the exact same issue and can't find the image file anywhere…
    SG-4860 as well and boots up to

    F6 PXE
    Boot: F1
    … and then nothing


Log in to reply