Unable to enable DHCP server for OPT1 interface



  • Hi!

    I'm trying to configure a DHCP server for my OPT1 interface.
    The problem is that there are no "tab" for the OPT1 interface under DHCP Server configuration in the web interface??

    The interface is assigned an IPv4 IP-adress and so on, if I connect a computer with a static IP to that interface I can
    reach the web interface.
    But still I'm unable to configure DHCP server on OPT1 interface… Though it works just fine for my LAN interface!
    Tried removing and adding the interface, rebooting, reconfigure and so on.

    Anyone who can help?
    Or just tell me "You stupid son of a ..., you just forgot about this simple thing!!" :P



  • When an interface has StaticIPv4 and a static IPv4 address and CIDR then there should be a tab for that interface in DHCP Server.

    Is the IPv4 type of the interface set to Static IPv4?

    What other odd settings did you make? (e.g. it should NOT have an upstream gateway specified)



  • Thank's for the reply! :)

    Well, I have configured it with an IPv4 address and no other settings modified.
    To me it's just the same as LAN except for the IP address, but I suppose something is off anyhow.. :P
    (attached screen shot)



  • Rebel Alliance

    @mindless:

    To me it's just the same as LAN except for the IP address,

    Is "not the same" ;)  you have  a /32  (LAN have /24 )



  • Omg!!
    I knew it was something really small and stupid I!!  :-[ ;D
    Think I have looked at that page like a 100 times and "It looks just like my LAN"..

    Now my DHCP server works just fine!

    Anyhow, thank you sooo much for noticing my stupid error! :)


  • Rebel Alliance

    You're welcome !

    Glad to be of help



  • @ptt:

    @mindless:

    To me it's just the same as LAN except for the IP address,

    Is "not the same" ;)  you have  a /32  (LAN have /24 )

    Saved me, thanks. You have a cold beer waiting for you anytime you're in northern Wisconsin