Resolved:DNS server not work



  • Hello,
    I Installed now the pfsense in my vmware infrastructure. I have one router from provider that nat all communication to ip of wan interface pfsense 192.168.1.2.
    I added another interface network to my vm pfsense in lan and enable the dhcp service. This service work well, i check it added one windows vm and the dhcp server of pfsense assign the right ip address attach file 1.
    When i would like to connect to google.it in my vm i can't. I think there are some problem with my DNS configuration. The configuration of my DNS is attach file 2.
    Can you help me to resolve my problem please?
    Thanks.






  • Hi,

    Set the DNS server to a server that has DNS entries, like google: 8.8.8.8
    Instead of 127.0.0.1

    Of course you can also use the DNS server from your provider.

    Wil


  • LAYER 8 Global Moderator

    Out of the box pfsense would point to itself and use the resolver for dns.  Your dhcp clients from pfsense would point to pfsense for their dns, which would resolve what your looking for.

    Your clients are set to ask googledns - so is that not working?  Are you blocking outbound 53 udp/tcp?

    Your going to have to give us a bit more to go on..  Out of the box pfsense should just work for dns - if not your isp is blocking 53, or hijacking or you got something infront of pfsense blocking dns.  Or you dicked it up on your own..



  • I haven't rule in pfsense firewall, you can see my wan list of rules. I must add one new rules in pfsense for open the port of DNS server.
    In my router from my provider i use the nat option and i have open all ports on the ip wan of pfsense.
    Can you tell me please all step that i must to do for configure the dns server.
    Thanks.




  • Resolved the problem.
    Thanks. i Open the port 53 on the Vodafone Station router.
    Now works.


  • LAYER 8 Global Moderator

    Why would you think you need to open ports on wan??

    So you have a router/firewall in front of pfsense?  What is the point of pfsense then??


Log in to reply