Installation kernel panic on driver load



  • Hi all – new here and new to the whole pfSense world, so please bear with me!

    I'm trying to repurpose an old Macbook Pro (mid-2010) and have pfSense run natively on the machine (or at least try before I go to a VM solution though OSX). Although I know it's challenging to run pfSense natively on Apple hardware, I've seen a few instances online where people have succeeded doing so (either with pfSense or FreeBSD in general) so I thought I would give it a try.

    I've been able to successfully boot the installer through the USB stick with rEFInd, however it looks like the installation hangs and throws a Fatal Trap Error 12 when loading the bwn0 driver.

    I tried with both the stable and the beta 64-bit releases, but they both present the same issue. Also tried the 32-bit stable, with no luck.

    I'm posting screenshots below from my attempts in hopes for a solution! Is there perhaps a way to prevent the bwn0 driver from being loaded, since the Broadcom wireless interface won't be used anyway in my setup?

    With version 2.3.4 (Stable, 64bit):

    With 2.4.0 Beta:

    Many many thanks in advance!


  • Netgate Administrator

    Hmm, fun!  :D

    You can see the driver does not actually attach.

    I would normally suggest disabling it in hardware of the BIOS but your options on a macbook are… limited.

    It might require different firmware...

    Can you type 'bt' at the prompr there to see the backtrace?

    Steve



  • Thank you for the prompt reply Stephen – yes..."fun" indeed!

    I cannot type anything on the prompt -- it's stuck. I even thought about ripping out the WLAN module from the macbook to avoid detection by the installer, but it's burried in the screen's hinge mechanism apparently. So no option here.

    Are there any parameters I can pass to the boot loader/installer maybe?


  • Rebel Alliance Developer Netgate

    If you can get to a loader prompt (and type in it), try this:

    set hint.bwn.0.disabled=1
    boot
    
    

    If that works, after install, add hint.bwn.0.disabled=1 to /boot/loader.conf.local


Log in to reply