PHP Errors Causing Possible Network Loss



  • I have been having some issues with my pfSense router. The WAN was dropping off and would need a reboot to resolve it. I have sense moved it to another port and that seems to have made it more stable, but the LAN is starting to do the same thing so I might have to move that one soon as well. I am also getting this error and I have no idea how to resolve it:

    PHP ERROR: Type: 64, File: -, Line: 3, Message: require_once(): Failed opening required '/usr/local/pkg/apache_mod_security.inc' (include_path='.:/etc/inc:/usr/local/www:/usr/local/captiveportal:/usr/local/pkg:/usr/local/www/classes:/usr/local/www/classes/Form')

    I removed most of my packages, and each time it generated a new error. I am guessing it is related to Apache restarting. I updated to the latest version just to see if that would resolve the issue (which it did not). The version is:

    2.3.4-RELEASE (amd64)
    built on Wed May 03 15:13:29 CDT 2017
    FreeBSD 10.3-RELEASE-p19

    System specs:
    CPU Type: Intel(R) Atom(TM) CPU D2550 @ 1.86GHz
    4 CPUs: 1 package(s) x 2 core(s) x 2 HTT threads
    RAM: 4GB
    SSD for Storage and OS
    5 NIC Adapters (I am also running VLANs)

    Anyone have any thoughts on logs I could check to see what is going on, or have a solution for the issue?



  • Disappointed so one has any thoughts or things I can look at. It has gotten to the point that I am losing Internet connection a lot and I am done with it. I backed up my config and I plan to reinstall pfSense to try and resolve this issue. Now my issue is finding an intact install file. I have tried both US based mirrors for USB Install and when I use 7zip to extract the contents, I am greeted with a broken package error. I am trying right now from Germany. I also tried the ISO from NY, that is broken as well. I am not sure if it is the files on the mirrors or my connection (which I am lucky has yet to drop even though it still reports the error that I posted). Either way, it is making this a very long and painful install.  >:(



  • Wow. I don't know what is wrong. I spent several hours trying to get the CD to work for rebuilding the firewall and nothing worked. I used a USB CD Drive to burn and read, but the boot up took forever. I transferred the ISO to my main computer and burned it on the internal CD Drive. This made it better. The firewall doesn't have a CD-ROM, but it is a computer so I hooked one up to the SATA port and it would not load the CD. So I went back to the USB CD-ROM and it booted, right up until it detected the USB CD-ROM then errors with mount issues (error 19 or 16, don't remember). I don't remember it being this hard to install pfSense. I had several issues just getting a working copy of the software from the sites (ended up downloading it on my Linux laptop and the hashes matched finally).

    In case you want to try calling me stupid or something for not using the USB installer, I already tried that. It was my first set of attempts before going to the CD-ROM. The BIOS doesn't detect the USB Boot Drive.


Log in to reply