Setting up multiwan



  • Hi all,

    I have been trying to setup multiwan with loadbalancing (I know "perfect" loadbalancing is not possible) with hopefully failover.

    My situation is like the following. I have a 10.x.x.x network. On 10.0.0.1 and 10.0.1.1 I have two DSL routers hooked up to independent connections. They perform routing and NAT to the internet.

    I have setup pfsense on 10.1.0.2, created a gateway group including the two other gateways. However, when I change my LAN rule to use the gateway group, things die; I can't connect to IM (ICQ, Gtalk), and traceroute goes:

    $ traceroute www.uab.es
    traceroute to www.uab.es (158.109.168.60), 30 hops max, 40 byte packets
    1  zyxel.sprawl (10.0.0.1)  4.093 ms router-cesar.sprawl (10.0.1.1)  6.324 ms zyxel.sprawl (10.0.0.1)  5.312 ms^C

    Meaning that packets go to either gateway for a single host- I would guess that I want "sticky" connections; i.e. unless there's a gateway down, outbound connections are loadbalanced, but connections to a single host always follow the same route.

    I have looked around, but I haven't seen anything…

    Ideas? Is there any guide about how to set up this?

    Alex





  • That's not for 1.3, I can't seem to find the way to activate sticky connections.



  • @koala:

    That's not for 1.3, I can't seem to find the way to activate sticky connections.

    To turn on sticky connections on 1.3 follow these instructions.

    1. Log in
    2. go to System->Advanced
    3. Click "Miscellaneous" tab
    4. Top check box is "Use sticky connections" check it and save.
    5. Done!



  • I just tried the same scenario. But whenever I turn on sticky connections, after some time I start getting timeouts and nothing goes out.
    Firewall logs show nothing. It just doesnt work. If I restart the firewall all is well until it happens again. Hardware is a PIII/733 with 786 RAM. The 2 WANs are 14mbit/1mbit DSLs. At the most heavy usage it had about 400 states active. This used to happen with 1.2 too but not that often.



  • 1.3 should now work a bit better.


Log in to reply