2 LAN Interfaces - Second one does not assign IPs



  • ISSUE FIXED (after another reboot and maybe some changes (?))

    Hey,

    I was extending my pfSense by adding a third NIC as a second LAN port. So far so good.
    The second LAN port is attached to my Access Point.
    However, connecting to the AP does not work. (Android is stuck at "obtaining ip address".) So I guess the DHCP server is not working on this interface.
    I tried to ping my main subnet and outside IPs using the second LAN interface. Working flawlessly.

    My firewall rules and DHCP settings for the LAN_AP interface:
    https://imgur.com/a/uafeU

    DHCP requests are not being logged in the DHCP logs, only once for my FireTV Stick, but not anymore.

    (I wasn't quite sure about the section this belongs to since I am not 100% certain where the issue's root is)


  • LAYER 8 Global Moderator

    did you enable dhcp on that interface?  What is the IP/network you put on this added interface optX - you would have to enable the dhcp server on it and setup the pool.  You would also then need to set firewall rules on this interface.

    While it would hand out IPs once you enable dhcp server.  Clients on this network would not be able to do anything until you create firewall rules since OPT interfaces do not have any default firewall rules.

    edit:  Ah you called your opt lan_AP..  That looks correct, connect a laptop or something to this port.. Does that work?  What are you using as AP?



  • My AP (temporarily) is a netgear wn3100rp.
    Using my Laptop does not work either (using a usb-lan donge. Have to see if I can get something attached to it w/o a donge, but I doubt that this would change anything).

    The weird thing right now is that I can no longer configure the AP after a factory reset even though it worked yesterday. So it must have worked once or I had some weird luck. Secondly, my FireTV Stick connected once while I was asleep.

    Edit: Attaching my AP to the main LAN port works flawlessly.
    So it has to be the port and not the AP.


Log in to reply