Failed to properly upgrade from 2.3.2



  • A few days ago we tried to upgrade from pfsense 2.3.2. On the dashboard it said 2.3.3_1 was available (I later found out that 2.3.4 had already been released, but it still showed this older version). So I went to upgrade from the web interface and it seemed to work alright and the system rebooted (I can't recall if I did it or it did automatically). Anyway, when it came back up, it appeared as though the upgrade only partially worked? There are two visible issues now (although so far the installation still seems to be functioning ok):

    1. In the web interface and shell, it still shows 2.3.2. No matter if I try to pkg update -f and pkg upgrade -f (which prompts me to reinstall a few packages) it does not fix the version numbers. I do not know if it's purely a cosmetic issue or if it's indicative of other critical components that also did not get upgraded. I should note that if I do uname -a in a shell, it does actually show pfsense 2.3.4, so I guess at least the kernel got upgraded…

    2. The dashboard always says "Unable to check for updates" although as previously noted, pkg update/upgrade seemingly work ok?

    One thing I did have to change post-upgrade (that I discovered while searching the forums here for my upgrade problem) was to uncheck the Allow DNS server list to be overridden by DHCP/PPP on WAN setting on the General Setup page in order to be able to get pkg to work correctly after the reboot.

    I should also note that in my Update Settings, I've never touched the Firmware Branch setting and it is currently on Stable (Default).

    At this point I do not know what else to do/try. I'd love to hear any suggestions/help anyone may have.


  • Rebel Alliance Developer Netgate

    First, go to the Update Settings and even if you do not change anything, press Save.

    Then from the shell check the output of these commands and post it here:

    pkg-static upgrade -f
    pkg-static version -vL=
    

    It should show the new versions there.

    After that, try updating from the shell using this command:

    pfSense-upgrade -d
    

    If that fails, post the output here as well.



  • Output of pkg-static upgrade -f:

    Updating pfSense-core repository catalogue…
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.
    Checking for upgrades (4 candidates): 100%
    Processing candidates (4 candidates): 100%
    Checking integrity... done (0 conflicting)
    The following 4 package(s) will be affected (of 0 checked):

    Installed packages to be REINSTALLED:
    pkg-1.10.1_1 [pfSense]
    nano-2.8.0 [pfSense]
    indexinfo-0.2.6 [pfSense]
    gettext-runtime-0.19.8.1_1 [pfSense]

    Number of packages to be reinstalled: 4

    Proceed with this action? [y/N]: y
    [1/4] Reinstalling indexinfo-0.2.6…
    [1/4] Extracting indexinfo-0.2.6: 100%
    [2/4] Reinstalling gettext-runtime-0.19.8.1_1…
    [2/4] Extracting gettext-runtime-0.19.8.1_1: 100%
    [3/4] Reinstalling pkg-1.10.1_1…
    [3/4] Extracting pkg-1.10.1_1: 100%
    You may need to manually remove /usr/local/etc/pkg.conf if it is no longer needed.
    [4/4] Reinstalling nano-2.8.0…
    [4/4] Extracting nano-2.8.0: 100%

    Output of pkg-static version -vL=:

    Updating pfSense-core repository catalogue…
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.

    Output of pfSense-upgrade -d:

    pkg: No package(s) matching pfSense-kernel-*

    Updating repositories metadata…
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.
    ERROR: Unable to compare version of pfSense-repo


  • Rebel Alliance Developer Netgate

    Looks like you might be missing a few core packages. So whatever the problem is, it happened a while ago and not now.

    Show the full output of:

    pkg info
    


  • Output of pkg info:

    gettext-runtime-0.19.8.1_1    GNU gettext runtime libraries and programs
    indexinfo-0.2.6                Utility to regenerate the GNU info page index
    nano-2.8.0                    Nano's ANOther editor, an enhanced free Pico clone
    pkg-1.10.1_1                  Package manager


  • Rebel Alliance Developer Netgate

    That's it? There should be many, many (many) more entries. Over 150, closer to 170.

    Something must have destroyed the pkg database at some point. Did you manually change anything in there?

    You might be able to recover.

    pkg install -y pfSense pfSense-base pfSense-repo pfSense-kernel-pfSense pfSense-rc pfSense-repo pfSense-upgrade
    

    That may pull in everything else with its dependencies.

    Post "pkg info" output again after running that.



  • I haven't done any manual changes from the shell or anything like that, just normal usage via the web interface and just recently the upgrade (also from the web) that seemingly failed.

    I will probably wait to install these packages until the end of the day in case something should go awry.


  • Rebel Alliance Developer Netgate

    Do you use the option to keep /var and /tmp in RAM? Or did you use it before and then turn it off?

    It's very unusual for the whole database to disappear like that but still have a few entries.

    And yeah, waiting for a good maintenance window would be ideal for making those changes. If it does work, you'll want to try the upgrade script again after. You might end up with 2.3.4 when the pkg command is done. Either way you'll want to reboot after making those changes.



  • Yes, we enabled Use memory file system for /tmp and /var during the initial installation a long while back because we have a full installation on an SSD. We have not changed that setting since installation.


  • Rebel Alliance Developer Netgate

    OK, there have been some problems with that in the past, so it's probably what happened on an earlier version. Reinstalling the packages like I mentioned above should hopefully get it back to normal.



  • I have the same problem:

    pkg-static upgrade -f
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.
    Checking for upgrades (188 candidates):  40%
    
    pfSense-kernel-pfSense-2.3.2_1 is locked and may not be modified
    Checking for upgrades (188 candidates): 100%
    Processing candidates (188 candidates): 100%
    The following 175 package(s) will be affected (of 0 checked):
    
    New packages to be INSTALLED:
    	libnghttp2: 1.18.0 [pfSense]
    	pfSense-upgrade: 0.21 [pfSense]
    	openvpn23: 2.3.14 [pfSense]
    	norm: 1.5r6 [pfSense]
    	libwww: 5.4.0_6 [pfSense]
    	liblz4: 131 [pfSense]
    	json-c: 0.12.1 [pfSense]
    
    Installed packages to be UPGRADED:
    	unbound: 1.5.9 -> 1.6.0 [pfSense]
    	uclcmd: 0.1 -> 0.1_1 [pfSense]
    	strongswan: 5.5.0 -> 5.5.1 [pfSense]
    	sqlite3: 3.13.0 -> 3.15.1_1 [pfSense]
    	python27: 2.7.12 -> 2.7.13_1 [pfSense]
    	php56-zlib: 5.6.26 -> 5.6.30 [pfSense]
    	php56-xmlwriter: 5.6.26 -> 5.6.30 [pfSense]
    	php56-xmlreader: 5.6.26 -> 5.6.30 [pfSense]
    	php56-xml: 5.6.26 -> 5.6.30 [pfSense]
    	php56-tokenizer: 5.6.26 -> 5.6.30 [pfSense]
    	php56-sysvshm: 5.6.26 -> 5.6.30 [pfSense]
    	php56-sysvsem: 5.6.26 -> 5.6.30 [pfSense]
    	php56-sysvmsg: 5.6.26 -> 5.6.30 [pfSense]
    	php56-sqlite3: 5.6.26 -> 5.6.30 [pfSense]
    	php56-sockets: 5.6.26 -> 5.6.30 [pfSense]
    	php56-simplexml: 5.6.26 -> 5.6.30 [pfSense]
    	php56-shmop: 5.6.26 -> 5.6.30 [pfSense]
    	php56-session: 5.6.26 -> 5.6.30 [pfSense]
    	php56-readline: 5.6.26 -> 5.6.30 [pfSense]
    	php56-posix: 5.6.26 -> 5.6.30 [pfSense]
    	php56-pfSense-module: 0.12 -> 0.13 [pfSense]
    	php56-pdo_sqlite: 5.6.26 -> 5.6.30 [pfSense]
    	php56-pdo: 5.6.26 -> 5.6.30 [pfSense]
    	php56-pcntl: 5.6.26 -> 5.6.30 [pfSense]
    	php56-openssl: 5.6.26 -> 5.6.30 [pfSense]
    	php56-opcache: 5.6.26_1 -> 5.6.30 [pfSense]
    	php56-mcrypt: 5.6.26 -> 5.6.30 [pfSense]
    	php56-mbstring: 5.6.26 -> 5.6.30 [pfSense]
    	php56-ldap: 5.6.26 -> 5.6.30 [pfSense]
    	php56-json: 5.6.26 -> 5.6.30 [pfSense]
    	php56-hash: 5.6.26 -> 5.6.30 [pfSense]
    	php56-gettext: 5.6.26 -> 5.6.30 [pfSense]
    	php56-filter: 5.6.26 -> 5.6.30 [pfSense]
    	php56-dom: 5.6.26 -> 5.6.30 [pfSense]
    	php56-curl: 5.6.26 -> 5.6.30 [pfSense]
    	php56-ctype: 5.6.26 -> 5.6.30 [pfSense]
    	php56-bz2: 5.6.26 -> 5.6.30 [pfSense]
    	php56-bcmath: 5.6.26 -> 5.6.30 [pfSense]
    	php56: 5.6.26 -> 5.6.30 [pfSense]
    	php-xdebug: 2.4.0 -> 2.4.1_1 [pfSense]
    	php-suhosin: 0.9.38 -> 0.9.38_3 [pfSense]
    	pftop: 0.7_6 -> 0.7_7 [pfSense]
    	pfSense-repo: 2.3.2_1 -> 2.3.3 [pfSense]
    	pfSense-rc: 2.3.2_1 -> 2.3.3_1 [pfSense-core]
    	pfSense-default-config: 2.3.2_1 -> 2.3.3_1 [pfSense-core]
    	pfSense-base: 2.3.2_1 -> 2.3.3_1 [pfSense-core]
    	pfSense-Status_Monitoring: 1.4.4_2 -> 1.6.1_3 [pfSense]
    	pfSense: 2.3.2_1 -> 2.3.3_1 [pfSense]
    	pecl-zmq: 1.1.3_1 -> 1.1.3_2 [pfSense]
    	pecl-ssh2: 0.12 -> 0.13 [pfSense]
    	pecl-rrd: 1.1.3_3 -> 1.1.3_4 [pfSense]
    	pecl-radius: 1.3.0 -> 1.4.0.b1 [pfSense]
    	pcre: 8.39 -> 8.39_1 [pfSense]
    	ntp: 4.2.8p8 -> 4.2.8p9_1 [pfSense]
    	nss: 3.25 -> 3.28.1_1 [pfSense]
    	nspr: 4.12 -> 4.13.1 [pfSense]
    	nginx: 1.10.1,2 -> 1.10.2_3,2 [pfSense]
    	nettle: 3.2 -> 3.3 [pfSense]
    	mysql56-client: 5.6.30 -> 5.6.35_1 [pfSense]
    	links: 2.9,1 -> 2.13,1 [pfSense]
    	libzmq4: 4.1.4_1 -> 4.1.5 [pfSense]
    	libssh2: 1.7.0,2 -> 1.8.0,2 [pfSense]
    	libsodium: 1.0.8 -> 1.0.11_1 [pfSense]
    	libpcap: 1.7.4 -> 1.8.1 [pfSense]
    	libiconv: 1.14_9 -> 1.14_10 [pfSense]
    	jansson: 2.7_3 -> 2.9 [pfSense]
    	isc-dhcp43-server: 4.3.4 -> 4.3.5 [pfSense]
    	isc-dhcp43-relay: 4.3.4_1 -> 4.3.5 [pfSense]
    	isc-dhcp43-client: 4.3.4 -> 4.3.5 [pfSense]
    	idnkit: 1.0_5 -> 1.0_6 [pfSense]
    	glib: 2.46.2 -> 2.46.2_4 [pfSense]
    	expat: 2.1.1_2 -> 2.2.0_1 [pfSense]
    	dhcp6: 20080615_7 -> 20080615.1 [pfSense]
    	curl: 7.50.3 -> 7.53.0 [pfSense]
    	ca_root_nss: 3.25 -> 3.28.1 [pfSense]
    	bind-tools: 9.10.4P2 -> 9.11.0P3 [pfSense]
    	barnyard2: 1.13 -> 1.13_1 [pfSense]
    
    Installed packages to be DOWNGRADED:
    	pkg: 1.10.1 -> 1.9.4_1 [pfSense]
    	p5-Net-SSLeay: 1.81 -> 1.78 [pfSense]
    	p5-IO-Socket-SSL: 2.044 -> 2.038 [pfSense]
    	p5-IO-Socket-IP: 0.39 -> 0.38 [pfSense]
    	net-snmp: 5.7.3_14 -> 5.7.3_11 [pfSense]
    
    Installed packages to be REINSTALLED:
    	xinetd-2.3.15_2 [pfSense]
    	wrapalixresetbutton-0.0.7 [pfSense]
    	wol-0.7.1_3 [pfSense]
    	whois-5.1.5_1 [pfSense]
    	vstr-1.0.15_1 [pfSense]
    	voucher-0.1_2 [pfSense]
    	suricata-3.1.2 [pfSense]
    	sshlockout_pf-0.0.2 [pfSense]
    	ssh_tunnel_shell-0.1 [pfSense]
    	smartmontools-6.5_1 [pfSense]
    	scponly-4.8.20110526_2 [pfSense]
    	rrdtool-1.6.0_1 [pfSense]
    	relayd-5.5.20140810_2 [pfSense]
    	rate-0.9_1 [pfSense]
    	radvd-1.9.1 [pfSense]
    	qstats-0.1_1 [pfSense]
    	python2-2_3 [pfSense]
    	pfSense-pkg-suricata-3.1.2_2 [pfSense]
    	pfSense-pkg-pfBlockerNG-2.1.1_7 [pfSense]
    	pfSense-pkg-nut-2.7.4_4 [pfSense]
    	pfSense-pkg-Shellcmd-1.0.2_3 [pfSense]
    	pfSense-pkg-Notes-0.2.9_2 [pfSense]
    	pfSense-pkg-Cron-0.3.7_1 [pfSense]
    	perl5-5.24.1.r4_1 [pfSense]
    	p5-Socket-2.024 [pfSense]
    	p5-Mozilla-CA-20160104 [pfSense]
    	p5-GSSAPI-0.28_1 [pfSense]
    	p5-Digest-HMAC-1.03_1 [pfSense]
    	p5-Authen-SASL-2.16_1 [pfSense]
    	openldap-client-2.4.44 [pfSense]
    	oniguruma5-5.9.6_1 [pfSense]
    	nut-2.7.4_1 [pfSense]
    	neon-0.30.1 [pfSense]
    	nano-2.7.3 [pfSense]
    	mpd5-5.8 [pfSense]
    	mpd4-4.4.1_1 [pfSense]
    	miniupnpd-1.9.20160113,1 [pfSense]
    	minicron-0.0.2 [pfSense]
    	lzo2-2.09 [pfSense]
    	luajit-2.0.4_1 [pfSense]
    	lua52-5.2.4 [pfSense]
    	lighttpd-1.4.44 [pfSense]
    	libyaml-0.1.6_2 [pfSense]
    	libxml2-2.9.4 [pfSense]
    	libucl-0.8.0 [pfSense]
    	libpdel-0.5.3_6 [pfSense]
    	libnet-1.1.6_4,1 [pfSense]
    	libmcrypt-2.5.8_3 [pfSense]
    	libltdl-2.4.6 [pfSense]
    	libidn-1.33_1 [pfSense]
    	libhtp-0.5.22 [pfSense]
    	libffi-3.2.1 [pfSense]
    	libevent2-2.0.22_1 [pfSense]
    	libedit-3.1.20150325_2,1 [pfSense]
    	libdaemon-0.14_1 [pfSense]
    	ldns-1.6.17_5 [pfSense]
    	ipmitool-1.8.17_1 [pfSense]
    	indexinfo-0.2.6 [pfSense]
    	igmpproxy-0.1_3,1 [pfSense]
    	icu-58.2,1 [pfSense]
    	grepcidr-2.0 [pfSense]
    	gogoc-1.2_1 [pfSense]
    	gmp-5.1.3_3 [pfSense]
    	gettext-runtime-0.19.8.1_1 [pfSense]
    	filterlog-0.1_4 [pfSense]
    	filterdns-1.0_9 [pfSense]
    	expiretable-0.6_1 [pfSense]
    	dpinger-2.0 [pfSense]
    	dnsmasq-2.76,1 [pfSense]
    	dmidecode-3.0 [pfSense]
    	dhcpleases6-0.1_2 [pfSense]
    	dhcpleases-0.3_1 [pfSense]
    	cyrus-sasl-2.1.26_12 [pfSense]
    	cpustats-0.1_1 [pfSense]
    	cpdup-1.18 [pfSense]
    	clog-1.0.1 [pfSense]
    	choparp-20150613 [pfSense]
    	check_reload_status-0.0.7 [pfSense]
    	bwi-firmware-kmod-3.130.20 [pfSense]
    	bsnmp-ucd-0.4.2 [pfSense]
    	bsnmp-regex-0.6_1 [pfSense]
    	broccoli-1.97,1 [pfSense]
    	beep-1.0_1 [pfSense]
    	ataidle-2.7.2 [pfSense]
    	aggregate-1.6_1 [pfSense]
    	GeoIP-1.6.9 [pfSense]
    
    Number of packages to be installed: 7
    Number of packages to be upgraded: 77
    Number of packages to be reinstalled: 86
    Number of packages to be downgraded: 5
    
    The process will require 8 MiB more space.
    98 MiB to be downloaded.
    
    Proceed with this action? [y/N]: y
    [1/175] Fetching pkg-1.9.4_1.txz: 100%    2 MiB 364.2kB/s    00:07    
    [2/175] Fetching xinetd-2.3.15_2.txz: 100%   79 KiB  81.2kB/s    00:01    
    [3/175] Fetching wrapalixresetbutton-0.0.7.txz: 100%    5 KiB   4.8kB/s    00:01    
    [4/175] Fetching wol-0.7.1_3.txz: 100%   29 KiB  29.4kB/s    00:01    
    [5/175] Fetching whois-5.1.5_1.txz: 100%   53 KiB  54.2kB/s    00:01    
    [6/175] Fetching vstr-1.0.15_1.txz: 100%  165 KiB 169.3kB/s    00:01    
    [7/175] Fetching voucher-0.1_2.txz: 100%    5 KiB   4.9kB/s    00:01    
    [8/175] Fetching unbound-1.6.0.txz: 100%  664 KiB 340.0kB/s    00:02    
    [9/175] Fetching uclcmd-0.1_1.txz: 100%   16 KiB  16.4kB/s    00:01    
    [10/175] Fetching suricata-3.1.2.txz: 100%  637 KiB 217.5kB/s    00:03    
    [11/175] Fetching strongswan-5.5.1.txz: 100%    1 MiB 241.2kB/s    00:05    
    pkg-static: cached package strongswan-5.5.1: size mismatch, fetching from remote
    [12/175] Fetching strongswan-5.5.1.txz: 100%    1 MiB 301.6kB/s    00:04    
    pkg-static: cached package strongswan-5.5.1: size mismatch, cannot continue
    
    


  • Totally forgot about this, but I did the manual package installation as suggested and it now installed 130 packages.

    pkg info now shows:

    
    ataidle-2.7.2                  Utility to spin down ATA drives
    beep-1.0_1                     Beeps a certain duration and pitch out of the PC Speaker
    bind-tools-9.11.1              Command line tools from BIND: delv, dig, host, nslookup...
    bsnmp-regex-0.6_1              bsnmpd module allowing creation of counters from log files
    bsnmp-ucd-0.4.2                bsnmpd module that implements parts of UCD-SNMP-MIB
    bwi-firmware-kmod-3.130.20     Broadcom AirForce IEEE 802.11 Firmware Kernel Module
    ca_root_nss-3.30.2             Root certificate bundle from the Mozilla Project
    check_reload_status-0.0.7      run various pfSense scripts on event.
    choparp-20150613               Simple proxy arp daemon
    clog-1.0.1                     Circular log support for FreeBSD syslogd
    cpdup-1.18                     Comprehensive filesystem mirroring and backup program
    cpustats-0.1_1                 cpustats
    curl-7.54.0                    Non-interactive tool to get files from FTP, GOPHER, HTTP(S) servers
    dhcp6-20080615.2               KAME DHCP6 client, server, and relay
    dhcpleases-0.3_1               read dhpcd.lease file and add it to hosts file
    dhcpleases6-0.1_2              read dhpcd6.leases file and trigger command on modification
    dmidecode-3.0                  Tool for dumping DMI (SMBIOS) contents in human-readable format
    dnsmasq-2.76,1                 Lightweight DNS forwarder, DHCP, and TFTP server
    dpinger-2.0                    IP device monitoring tool
    expat-2.2.0_1                  XML 1.0 parser written in C
    expiretable-0.6_1              Utility to remove entries from the pf(4) table based on their age
    filterdns-1.0_9                filterdns
    filterlog-0.1_4                filterlog
    gettext-runtime-0.19.8.1_1     GNU gettext runtime libraries and programs
    glib-2.46.2_5                  Some useful routines of C programming (current stable version)
    gmp-6.1.2                      Free library for arbitrary precision arithmetic
    idnkit-1.0_6                   Library to handle internationalized domain names
    igmpproxy-0.1_3,1              Multicast forwarding IGMP proxy
    indexinfo-0.2.6                Utility to regenerate the GNU info page index
    ipmitool-1.8.18                CLI to manage IPMI systems
    isc-dhcp43-client-4.3.5        The ISC Dynamic Host Configuration Protocol client
    isc-dhcp43-relay-4.3.5         The ISC Dynamic Host Configuration Protocol relay
    isc-dhcp43-server-4.3.5        ISC Dynamic Host Configuration Protocol server
    json-c-0.12.1                  JSON (JavaScript Object Notation) implementation in C
    ldns-1.7.0                     Library for programs conforming to DNS RFCs and drafts
    libdaemon-0.14_1               Lightweight C library that eases the writing of UNIX daemons
    libedit-3.1.20150325_2,1       Command line editor library
    libevent-2.1.8                 API for executing callback functions on events or timeouts
    libffi-3.2.1                   Foreign Function Interface
    libiconv-1.14_10               Character set conversion library
    libidn-1.33_1                  Internationalized Domain Names command line tool
    libltdl-2.4.6                  System independent dlopen wrapper
    libmcrypt-2.5.8_3              Multi-cipher cryptographic library (used in PHP)
    libnghttp2-1.21.0              HTTP/2.0 C Library
    libpdel-0.5.3_6                Packet Design multi-purpose C library for embedded applications
    libsodium-1.0.12               Library to build higher-level cryptographic tools
    libssh2-1.8.0,3                Library implementing the SSH2 protocol
    libucl-0.8.0                   Universal configuration library parser
    libxml2-2.9.4                  XML parser library for GNOME
    libzmq4-4.1.5                  ZeroMQ core library (Version 4)
    links-2.13,1                   Lynx-like text WWW browser
    lzo2-2.10_1                    Portable speedy, lossless data compression library
    minicron-0.0.2                 very small cron
    miniupnpd-1.9.20160113,1       UPnP IGD implementation which uses pf/ipf
    mpd4-4.4.1_1                   Multi-link PPP daemon based on netgraph(4)
    mpd5-5.8                       Multi-link PPP daemon based on netgraph(4)
    nano-2.8.0                     Nano's ANOther editor, an enhanced free Pico clone
    nettle-3.3                     Low-level cryptographic library
    nginx-1.10.3_1,2               Robust and small WWW server
    norm-1.5r6                     NACK-Oriented Reliable Multicast (NORM)
    ntp-4.2.8p10_2                 The Network Time Protocol Distribution
    oniguruma5-5.9.6_1             BSDL Regular Expressions library compatible with POSIX/GNU/Perl
    openldap-client-2.4.44         Open source LDAP client implementation
    openvpn23-2.3.14               Secure IP/Ethernet tunnel daemon
    pcre-8.40                      Perl Compatible Regular Expressions library
    pecl-radius-1.4.0.b1           Radius client library for PHP
    pecl-rrd-1.1.3_4               PHP bindings to rrd tool system
    pecl-ssh2-0.13                 PECL extension to the libssh2 library
    pecl-zmq-1.1.3_2               PHP bindings for ZeroMQ
    perl5-5.24.1                   Practical Extraction and Report Language
    pfSense-2.3.4                  Meta package to install pfSense required ports
    pfSense-Status_Monitoring-1.6.1_3 pfSense Status Monitoring
    pfSense-base-2.3.4             pfSense core files
    pfSense-kernel-pfSense-2.3.4   pfSense kernel (pfSense)
    pfSense-rc-2.3.4               pfSense rc script
    pfSense-repo-2.3.4             Setup pfSense pkg(8) repositories
    pfSense-upgrade-0.22_1         pfSense upgrade script
    pftop-0.7_8                    Utility for real-time display of statistics for pf
    php-suhosin-0.9.38_3           PHP extension that implements high-level protections
    php-xdebug-2.5.0               Xdebug extension for PHP
    php56-5.6.30                   PHP Scripting Language
    php56-bcmath-5.6.30            The bcmath shared extension for php
    php56-bz2-5.6.30               The bz2 shared extension for php
    php56-ctype-5.6.30             The ctype shared extension for php
    php56-curl-5.6.30              The curl shared extension for php
    php56-dom-5.6.30               The dom shared extension for php
    php56-filter-5.6.30            The filter shared extension for php
    php56-gettext-5.6.30           The gettext shared extension for php
    php56-hash-5.6.30              The hash shared extension for php
    php56-json-5.6.30              The json shared extension for php
    php56-ldap-5.6.30              The ldap shared extension for php
    php56-mbstring-5.6.30          The mbstring shared extension for php
    php56-mcrypt-5.6.30            The mcrypt shared extension for php
    php56-opcache-5.6.30           The opcache shared extension for php
    php56-openssl-5.6.30           The openssl shared extension for php
    php56-pcntl-5.6.30             The pcntl shared extension for php
    php56-pdo-5.6.30               The pdo shared extension for php
    php56-pdo_sqlite-5.6.30        The pdo_sqlite shared extension for php
    php56-pfSense-module-0.13      Library for getting useful info
    php56-posix-5.6.30             The posix shared extension for php
    php56-readline-5.6.30          The readline shared extension for php
    php56-session-5.6.30           The session shared extension for php
    php56-shmop-5.6.30             The shmop shared extension for php
    php56-simplexml-5.6.30         The simplexml shared extension for php
    php56-sockets-5.6.30           The sockets shared extension for php
    php56-sqlite3-5.6.30           The sqlite3 shared extension for php
    php56-sysvmsg-5.6.30           The sysvmsg shared extension for php
    php56-sysvsem-5.6.30           The sysvsem shared extension for php
    php56-sysvshm-5.6.30           The sysvshm shared extension for php
    php56-tokenizer-5.6.30         The tokenizer shared extension for php
    php56-xml-5.6.30               The xml shared extension for php
    php56-xmlreader-5.6.30         The xmlreader shared extension for php
    php56-xmlwriter-5.6.30         The xmlwriter shared extension for php
    php56-zlib-5.6.30              The zlib shared extension for php
    pkg-1.10.1_1                   Package manager
    python27-2.7.13_3              Interpreted object-oriented programming language
    qstats-0.1_1                   read dhpcd.lease file and add it to hosts file
    radvd-1.9.1                    Linux/BSD IPv6 router advertisement daemon
    rate-0.9_1                     Traffic analysis command-line utility
    relayd-5.5.20140810_2          OpenBSD relay daemon
    rrdtool-1.6.0_1                Round Robin Database Tools
    scponly-4.8.20110526_2         Tiny shell that only permits scp and sftp
    smartmontools-6.5_2            S.M.A.R.T. disk monitoring tools
    sqlite3-3.17.0                 SQL database engine in a C library
    ssh_tunnel_shell-0.1           SSH tunnel shell
    sshlockout_pf-0.0.2            SSH lockout pf
    strongswan-5.5.1_1             Open Source IKEv2 IPsec-based VPN solution
    uclcmd-0.1_1                   Command line tool for working with UCL config files
    unbound-1.6.1                  Validating, recursive, and caching DNS resolver
    voucher-0.1_2                  Voucher support
    vstr-1.0.15_1                  General purpose string library for C
    wol-0.7.1_3                    Tool to wake up Wake-On-LAN compliant computers
    wrapalixresetbutton-0.0.7      Utility to detect platform reset button state for use in scripting
    xinetd-2.3.15_2                Replacement for inetd with better control and logging
    
    


  • After a reboot, I started seeing PHP warnings for every PHP module it seems in both the console and a "crash report" notification on the web GUI.

    The warnings look like this:

    [28-May-2017 16:17:52 America/New_York] PHP Warning:  Module 'bcmath' already loaded in Unknown on line 0

    Any way to get rid of these? I'm not sure if it's harmful to any services running or not, but it definitely does get in the way when using the console.

    … On the bright side though, the system now reports a 2.3.4-RELEASE version on the console and web and the check for updates no longer fails.

    EDIT: I found what the problem with PHP was. In /usr/local/etc/php there were already individual files for each extension and /usr/local/etc/php/extensions.ini had entries for each of those extensions, so it was loading them twice. I simply commented out each line in /usr/local/etc/php/extensions.ini and all is well again.

    Thanks jimp!



  • In my case I decided to go with a clean install 2.3.4 and backup restore config.

    To bad we can't use full-upgrade file still available for download as before.



  • @mscdex:

    After a reboot, I started seeing PHP warnings for every PHP module it seems in both the console and a "crash report" notification on the web GUI.
    The warnings look like this:

    [28-May-2017 16:17:52 America/New_York] PHP Warning:  Module 'bcmath' already loaded in Unknown on line 0

    Likely could have been resolved by running: /etc/rc.php_ini_setup or on console using option '16) restart PHP-FPM'