[SOLVED] Accessing Web GUI from LAN without IP address



  • Hey all,

    So I just installed pfSense for the first time, and I'm using it to help learn a bit more about networking.

    The install was successful, and I've got most everything set up by following various tutorials I've found online.

    One thing I'm having trouble with, though, is accessing the web GUI using the host name I gave the machine.

    My hardware setup is illustrated in the attached image.

    Right now, only the LAN interface is active (I haven't even hooked it up to the WAN yet).  And in going through the setup wizard, I configured the following:

    LAN IP: 192.168.78.1
    Hostname: cuyahoga
    domain: localdomain

    What I would like to do is access the Web GUI by typing 'cuyahoga.localdomain' instead of typing the IP address, but it doesn't currently work.

    I know there must be a DNS setting that I am missing that would allow me to do this, because it's clear the client VM does not know how to resolve 'cuyahoga.localdomain', but I can't seem to figure out which option will allow me to do this.

    Any help is greatly appreciated.

    Thanks

    -Sean

    Edit: pfSense box IP



  • You might try checking to make sure your IP addresses are typed correctly here and on your DNS server.



  • In the browser search type

    http://cuyahoga



  • @coxhaus:

    You might try checking to make sure your IP addresses are typed correctly here and on your DNS server.

    There was definitely a typo in my post.  The IP address of the pfSense box is 192.168.78.1, and I've double checked on the system too.  Thanks for pointing out my error!

    @Chrismallia:

    In the browser search type

    http://cuyahoga

    I've tried this, and I just get a "Server not found" error.

    I'm sure I'm just misunderstanding something about how DNS works, so please forgive my ignorance.  My current settings are in the attached images.

    Note that I have tried adding the pfSense box to the host overrides section (though as I'm typing this I'm thinking that was a futile effort).

    Thanks for the responses, and again, please excuse my lack of knowledge.








  • What are the dns servers and search domains configured on the web browser computer?



  • If you are using windows make sure the network is private



  • @gjaltemba:

    What are the dns servers and search domains configured on the web browser computer?

    Currently the DNS servers entry is blank, which would probably explain why it doesn't resolve… the search domains are 'localdomain' (see attached image).  Obviously I need to reference a DNS server here to make things work, but what do I put there?  The pfSense box IP, or the hostname?




  • @Chrismallia:

    If you are using windows make sure the network is private

    The system I am using to access the Web GUI is an Ubuntu VM on a Windows host.  The Windows host network is not explicitly private (on a corporate domain currently).  But I've disabled DHCP and my Ubuntu VM has a static IP.



  • Cant you try from a other machine/laptop to rule out the dns



  • Try 192.168.78.1 as dns on ubuntu.



  • @Chrismallia:

    Cant you try from a other machine/laptop to rule out the dns

    I will try this out shortly and reply back.

    @gjaltemba:

    Try 192.168.78.1 as dns on ubuntu.

    Tried this, and added the hostname/IP of the pfSense box back to the hostname overrides, but no luck.



  • Trying the new machine See that its on private network and do  http://cuyahoga



  • Have you tried pfSense webui Diagnostics->DNS Lookup  cuyahoga.localdomain

    What is the output of dig @192.168.78.1 cuyahoga.localdomain from ubuntu?



  • @Chrismallia:

    Trying the new machine See that its on private network and do  http://cuyahoga

    Alright so I separated my machine from the corporate domain, and enabled DHCP on pfSense's LAN.  From Windows 7, I have obtain IP and DNS automatically, and http://cuyahoga still does not work.  I don't have to add the pfSense box's information to the host override, do I?

    Note that I can access the GUI via IP address.



  • @gjaltemba:

    Have you tried pfSense webui Diagnostics->DNS Lookup  cuyahoga.localdomain

    What is the output of dig @192.168.78.1 cuyahoga.localdomain from ubuntu?

    Alright I ran the dns lookup and got the results in the attached image.  I then clicked add alias, and that seems to have done the trick, I can access via http://cuyahoga.localdomain and http://cuyahoga.

    I than ran the dig command and got the attached results.

    So this obviously solved the problem, but what exactly is happening when I add the alias?  Also, can I view aliases in another part of the webui?






  • Glad you got it working.

    Firewall->Aliases is not hard to find.



  • @gjaltemba:

    Glad you got it working.

    Firewall->Aliases is not hard to find.

    Thanks for the help!