Intel D865GBF can't install 1.2x or 1.3x



  • So this weekend, I put together this pfsense box:

    http://forum.pfsense.org/index.php/topic,12270.0.html

    And I've had nothing but head-scratching problems since ;)

    The motherboard I'm using is an Intel D865GBF:

    http://www.intel.com/support/motherboards/desktop/D865GBF/

    I have a 160GB SATA HD, and a cd-rom connected to the PATA interface.  Network is onboard intel, and an intel dual-NIC card.  It was my intention to install the 1.2x release version to the HD, disconnect the CD-ROM and be done.

    The 1.2x version loads from CD just fine, and I can assign all 3 interfaces and access the web config page.  When I install to HD, the installer completes without issue.  When I reboot and remove the cd, the initial F1 FreeBSD msg comes up, and immediately after it goes to seemingly random characters that fill the screen and scroll vertically too fast to interpret.  I tried various combinations of legacy and enhanced disk modes in the bios as well as single and multi-processor kernels during the install, and the "packet mode" switch on and off during the installation.

    The 1.3x version also loads from CD just fine, and installs just fine, but after the reboot and removal of the CD, it hangs at the initial F1 FreeBSD msg.  I tried the same monkeying with kernels, loader options, and enhanced/legacy drive modes in the bios.

    I'm currently running the box from the 1.3x cd in production (yes I know bad idea, but it was better than trying to put the rats nest of old equip back in place).  I used the webconfig last night to set up the interfaces, and put enough firewall rules in place to get things moving, but this morning the web interface is inaccessible.  The box is still routing traffic though.

    I have other boards around, but I went with this one because of the onboard intel nic.  I saw other posts with similar issues with 865 chipset boards. 
    Is this board a dead-end with pfsense?  I know the hardware is stable as I ran an active linux lamp server on the same mobo for 2 yrs.  I know linux isn't freebsd, im just saying the hardware itself is OK.

    This is my first time using pfsense (it's replacing a cisco 2500 series, sonicwall firewall, and Dlink NAT router), and i REALLY like the interface/features but these hardware issues have me at wits end right now.

    -Rich



  • Have you tried disabling UDMA support via boot flags?

    http://forum.pfsense.org/index.php/topic,11016.msg61193.html#msg61193

    This could account for why the install goes ok then craps out on the reboot! I found this out when installing to microdrive, the /boot/loader.conf is different on the cd to the one that gets installed on the hard drive.

    Just a thought - and worth a go.



  • seemingly random characters that fill the screen and scroll vertically too fast to interpret

    I've seen that some time ago too and if i remember correctly I switch to a old ATA disk.
    http://devwiki.pfsense.org/BootOptions
    http://devwiki.pfsense.org/BootTroubleShooting



  • Thanks for the suggestions.

    I'm going to start by trying the GAG boot manager (http://gag.sourceforge.net/), and if that doesn't work, I'll try a smaller IDE hard drive (instead of the current SATA one).  I'll let you guys know how I make out.

    -Rich



  • Ok, the issue is definetely disk/controller related.

    40GB IDE HD - works!
    250GB IDE HD w/80 pin cable - same fail (scrolling codes in 1.2x and "F1  " fail in 1.3x)
    250GB IDE HD w/40-pin cable - shows being forced to UDMA33 at live cd boot, but same fail (scrolling codes in 1.2x and "F1  " fail in 1.3x)

    ANY drive I've tried so far connected to the onboard SATA interface fails the same as above.

    I'm reluctant to actually "go with" using the 40GB drive as in my opinion a firewall should be the MOST reliable piece of equipment in an environment and using an 8 yr old drive off my shelf makes it the LEAST reliable piece of equipment.

    -Rich



  • ohh and the GAG bootloader didn't make any difference in any of the situations I tried it  :(



  • Have now additionally tried an ancient Promise Technology PDC20267 Ultra100 PCI IDE adapter.  Interestingly, even though it doesn't appear on the HCL, the live cd and install did pick it up, and let me install to it without errors, but the system refuses to boot from it even when it's explicitly selected in the BIOS.  It just says no bootable media in device, and GAG doesn't see the drive at all.

    On the flip side, I'm getting really good at plugging and unplugging cables on the back of the box when the live cd boots to assign the interfaces  ;D ;D ;D ;D

    -Rich



  • A-HA!

    Since the 40GB IDE drive worked and everything else laughed in my face, I tried the SATA drive, with a manual CHS during install of:

    77545/16/63

    AND IT WORKED!!!

    -Rich



  • This is live and in production now.  To be clear for the next poor guy that tries to get pfSense working on an 865 chipset mobo with a modern hard disk, you can leave the drive in enhanced mode with bus mastering turned on etc. (basically the bios defaults).  The problem doesn't lie with DMA, enhanced or legacy modes, etc. with this mobo.  The problem is with how the HD geometry gets reported or detected during the install with both 1.2x and 1.3x.  When I entered a CHS manually during the install, all the problems I had with booting disappeared.

    The CHS I used was:

    77545/16/63

    This will give you approx. 40GB of usable space on your HD which is more than enough for pfSense.  The drive I'm using is actually 160GB, but I could care less :)  My goal was to configure the box with a modern HD that I knew I could count on for at least a few years.

    -Rich H.


Log in to reply