L2TP / IPSEC Does not work



  • Hello,

    I have setup L2TP / IPSEC Remote Access Server. But it does not work.

    It deletes IKE SA everytime. Here is the logs.

    May 23 14:53:45 charon 15[IKE] <con2|15>deleting IKE_SA con2[15] between 72.142.116.111[72.142.116.111]…173.35.88.88[192.168.50.116]
    May 23 14:53:45 charon 15[IKE] <con2|15>received DELETE for IKE_SA con2[15]
    May 23 14:53:45 charon 15[ENC] <con2|15>parsed INFORMATIONAL_V1 request 2181104782 [ HASH D ]
    May 23 14:53:45 charon 15[NET] <con2|15>received packet: from 173.35.88.88[56785] to 72.142.116.111[4500] (92 bytes)
    May 23 14:53:45 charon 08[IKE] <con2|15>closing CHILD_SA con2{6} with SPIs cdb8cdfd_i (786 bytes) a7d6c698_o (0 bytes) and TS 72.142.116.111/32|/0[udp/l2f] === 173.35.88.88/32|/0[udp/l2f]
    May 23 14:53:45 charon 08[IKE] <con2|15>received DELETE for ESP CHILD_SA with SPI a7d6c698
    May 23 14:53:45 charon 08[ENC] <con2|15>parsed INFORMATIONAL_V1 request 2614179208 [ HASH D ]
    May 23 14:53:45 charon 08[NET] <con2|15>received packet: from 173.35.88.88[56785] to 72.142.116.111[4500] (76 bytes)
    May 23 14:53:10 charon 08[IKE] <con2|15>CHILD_SA con2{6} established with SPIs cdb8cdfd_i a7d6c698_o and TS 72.142.116.111/32|/0[udp/l2f] === 173.35.88.88/32|/0[udp/l2f]
    May 23 14:53:10 charon 08[ENC] <con2|15>parsed QUICK_MODE request 1 [ HASH ]
    May 23 14:53:10 charon 08[NET] <con2|15>received packet: from 173.35.88.88[56785] to 72.142.116.111[4500] (60 bytes)</con2|15></con2|15></con2|15></con2|15></con2|15></con2|15></con2|15></con2|15></con2|15></con2|15></con2|15>



  • what are your clients running?  I use ipsec  (Not L2TP) and all clients have no issues.  Flawless.



  • How is Ipsec different from L2TP?



  • Kapara,

    I use windows 10.

    I setup L2TP/IPSEC using this link https://doc.pfsense.org/index.php/L2TP/IPsec

    As you mentioned we can use just IPSec for Remote Access On Pfsesne.

    Can you send me the Instructions for it ?



  • @kapara:

    what are your clients running?  I use ipsec  (Not L2TP) and all clients have no issues.  Flawless.

    Kapara,

    I use windows 10.

    I setup L2TP/IPSEC using this link https://doc.pfsense.org/index.php/L2TP/IPsec

    As you mentioned we can use just IPSec for Remote Access On Pfsesne.

    Can you send me the Instructions for it ?