Bios time correct, but pfsense according to logs clock is advancing



  • In BIOS I have set time correctly and it is not fast or slow atleast not this much. It seems to me that it's allways double the normal speed.

    Can I see clock in real time somehow, because I'm starting to think that log system is hosed after upgrade latest snapshot to beta4. I cleared the firewall log and then pfsense block something and the timestamp is 21.56. I do the same thing to system log and next action is marked with timestamp 15.25 :).

    Or maybe it's time to do clean install and only restore firewall rules.



  • Check your timezone setting in System -> General.



  • It is correctly set to Europe/Helsinki, but there is no logic to this kind of behaviour. I also tried GMT +3. Is there a way see clock in realtime to confirm that it is advancing?



  • @Switch:

    It is correctly set to Europe/Helsinki, but there is no logic to this kind of behaviour. I also tried GMT +3. Is there a way see clock in realtime to confirm that it is advancing?

    msntp outputs debugging information to Stauts -> System Logs



  • May 18 16:26:41 syslogd: kernel boot file is /boot/kernel/kernel
    May 18 16:26:41 syslogd: exiting on signal 15
    May 18 16:44:30 msntp[3332]: msntp: using NTP server pool.ntp.org (64.81.53.140)
    May 18 16:44:29 msntp[3332]: msntp: different parameters for restart
    May 18 16:44:29 msntp[3332]: d=18000 c=5 x=18000 op=1 l=/var/run/msntp.pid f=/var/db/msntp.state pool.ntp.org
    May 18 16:44:29 msntp[3332]: msntp options: a=2 p=0 v=1 e=0.100 E=5.000 P=2147483647.000

    Yes it's fast. Other thing is that the time should be 22:26. I try GMT -3. But the correct value should be Helsinki or GMT +3 here in Finland.



  • Ok, now time is correct according to System log 22.50, but still fast and firewall log is at GMT +3 time 16.50. Quite interesting :).



  • Clean install did not help. Exatly the same problems exists. Fcuk.. it might also be my H/W MS-5169 + K6-2 500 :). I already changed bios battery and bad caps. There is one mosfet that looks suffered from heat, but I don't think that has anything to do with this. Just guessing here.. it might be good idea to test with Athlon H/W.



  • Yes, please test with different hardware, you seem to be the only one with this problem.



  • I googled a bit and I found out that atleast someone using BSD 5.x had problems with some mobo's fast clock. And he/she also had clock working correcly in other OS(Win/Linux). I understood that BSD calculates is's own time separate from system bios. Maybe that is where the problem lies.

    Also I found these in system log:
    "kernel: Timecounter "i8254" frequency 1193182 Hz quality 0".
    "kernel: Timecounter "ACPI-safe" frequency 3579545 Hz quality 1000".
    "kernel: Timecounters tick every 1.000 msec kernel: Timecounter "TSC" frequency 501138058 Hz quality 800."

    What does these mean?" These doesn't seem to be errors.

    Someone had a fix using TSC(?) instead of new method introduced on 5.x, but I think pfSense is using TSC. I guess then it might be the only way to change the hardware to more current one.

    And Poul-Henning Kamp obviously has figured out some better way to calculate time in problem systems.

    Maybe this is the reason for RRD graphs showing only 2h and 6h timelines, others nan.



  • pfSense is using ACPI after all. I booted system ACPI disabled and problem disappeard.

    Is there any problems if I don't use ACPI? Should try to change time counter to TSC from ACPI and not to disable ACPI completely?



  • Edit your /etc/sysctl.conf and add kern.timecounter.hardware=TSC. That's it.. problem solved!


Log in to reply