Problemas com Hardware



  • Pessoal, comprei um hardware especifico para colocar o PC e está dando esse erro direto. Não consegui colocar o mesmo em produção:

    Reset never completed
    re0: phy write failed pfsense

    Hardware:

    re0@pci0:1:0:0: class=0x020000 card=0x012310ec chip=0x816810ec rev=0x02 hdr=0x00
        vendor    = 'Realtek Semiconductor Co., Ltd.'
        device    = 'RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller'
        class      = network
        subclass  = ethernet
    re1@pci0:2:0:0: class=0x020000 card=0x012310ec chip=0x816810ec rev=0x02 hdr=0x00
        vendor    = 'Realtek Semiconductor Co., Ltd.'
        device    = 'RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller'
        class      = network
        subclass  = ethernet
    re2@pci0:4:0:0: class=0x020000 card=0x81681849 chip=0x816810ec rev=0x11 hdr=0x00
        vendor    = 'Realtek Semiconductor Co., Ltd.'
        device    = 'RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller'
        class      = network
        subclass  = ethernet



  • Está instalando a 2.3.4?

    Achei um tópico sobre esse erro com realtek mas é bem antigo

    https://forum.pfsense.org/index.php?topic=9789.0



  • Sim amigo, é a ultima versão do PF.



  • @marcioelifas:

    Sim amigo, é a ultima versão do PF.

    De tudo o que consegui encontrar pesquisando, parece ser bug do driver do sistema operacional. Em alguns posts, voltando para uma versão específica, 'contorna' o problema.

    http://muc.lists.freebsd.bugs.narkive.com/b7JGegS8/kern-130011-re0-phy-write-failed-rtl8111c-problem

    Já tentou uma versão um pouco mais antiga?

    Não encontrei nada que relatasse esse erro no Freebsd10.



  • Marcelo, acabei de ver que em um cliente com a versão 2.3.2 não está ocorrendo problemas e possui o mesmo hardware.
    Vou realizar o teste e posto aqui se for ok. Muito obrigado!



  • Feito, na versão 2.3.2 não ocorre o problema. Vamos ver se na próxima versão arrumam, pq uma hora vou ter que atualizar os appliances…



  • @marcioelifas:

    Feito, na versão 2.3.2 não ocorre o problema. Vamos ver se na próxima versão arrumam, pq uma hora vou ter que atualizar os appliances…

    Abre um ticket no redmine do pfSense. Esta questão de driver precisa ser relatada.



  • Marcelo,
    Esquece, a versão que coloquei só demorou mais para aparecer o erro ¬¬
    Não sei mais o que fazer!!!