SWAP sem motivo (resolvido)



  • Boa tarde galera, dei uma procurada no forum mas não encontrei nada… (até encontrei mas realmente o cara não tinha memória na máquina) enfim estou com um pfsense em uma máquina com 4 gb de ram, porém mesmo utilizando só 24% ele esta usando swap, alguém ai poderia me dar uma mão? segue print da tela, estou na versão 2.3.3-RELEASE-p1 (amd64).

    Obrigado



  • Está usando algum pacote como squid com splice all habilitado por exemplo?

    O swap pode ter acontecido em outro momento, quando a memória estava perto do 100%?



  • Fala Marcelo, tudo bem? Estou sim, Squid e SquidGuard autenticando pelo AD, mas estranho porque antes de atualizar os pacotes nunca tive esse problema e sempre que monitoro a memória nunca chega perto nem de 50%. e com relação a splice cara não sei o que significa desculpa a ignorância nesse ponto…

    Existe alguma forma de corrigir isso?

    Valeu

    Abs



  • O splice all é opção de configuração da interceptação de SSL.

    Já que está monitorando o consumo de memória da máquina, você pode configurar ou executar um restart do serviço caso o squid atinga x de consumo.



  • Beleza, vou programa o restart do serviço.

    Muito obrigado.



  • Acredito que o consumo exagerado é um problema específico da versão atual do binário do squid ou parâmetros de compilação. Deve resolver nas versões futuras.

    https://forum.pfsense.org/index.php?topic=131180.0



  • Realmente, porque nunca tive esse problema até a última atualização…  Não sei se de repente atualizar o pfsense para a versão 2.3.4 possa afetar a forma como o squid trabalha, pela documentação não... enfim o jeito é aguardar a próxima versão.

    de qualquer forma obrigado pela ajuda.