OpenVPN password prompt on boot



  • I have an issue very similar to this thread https://forum.pfsense.org/index.php?topic=123054.0

    I get a prompt for a password on system boot. I assume it is also something I have configured wrong in my VPN settings. Here is a screenshot of my config http://imgur.com/a/lhd0i

    Is the server mode setting wrong or is it my server cert setting?


  • Netgate Administrator

    I expect that to come from an OpenVPN client rather than the server, do you have any configured?

    Otherwise it can be from an encrypted cert as mentioned in that other thread.

    Steve



  • Here are some screen shots of my client page. I do have two clients configured

    http://imgur.com/a/iqK2Q


  • Netgate Administrator

    Ok, it looks like you have two clients trying to connect to the same server on the same port using the same user. I'm not sure why you'd want that.

    However they are using different TLS keys, only one can be correct if they connect to the same server.

    The second client also has no password filled in so if that server requires a username/password that's probably the issue. Try disabling that client.

    Both clients are using the server certificate as their cert which is almost certainly incorrect. Even if it's for some reason what you chose to do it's a server cert not a client cert.

    Steve



  • Looks like you were right Steve when I disabled the client without a password and rebooted it didn't prompt me! I am not sure why I configured two clients, I probably just messed up when setting it up. I didn't realize they couldn't both use the same port. Thank you for your help figuring this out. Turns out I just did something stupid configuring OpenVPN.