NAS4FREE Behind openVPN



  • I have a problem since long and can not able to find a solution. Can anybody help me to up?

    I have openVPN set properly as I can connect to my DVR remotely but can not ping or access NAS4FREE and owncloud through openVPN.

    here is my network:

    Pfsense 192.168.0.1
    Netmask 255.255.255.0

    my Nas4Free ip 192.168.0.250
    port 12000
    owncloud on port 10000

    Open Tunnel network.
    10.0.7.0/24
    netmask 255.255.255.0

    my remote network
    192.168.10.0/24
    netmask 255.255.255.0

    C:>route print | find "10.0.7.1"
                0.0.0.0        128.0.0.0        10.0.7.1        10.0.7.2    276
            128.0.0.0        128.0.0.0        10.0.7.1        10.0.7.2    276
          192.168.0.0    255.255.255.0  10.0.7.1        10.0.7.2    276

    C:>route print | find "192.168.0.2"
          169.254.0.0      255.255.0.0    192.168.0.22      1

    C:>route print | find "192.168.0.22"
          169.254.0.0      255.255.0.0    192.168.0.22      1


  • Netgate Administrator

    I assume that route print is from the remote OpenVPN client? And that it's on 192.168.10.X locally so it does not conflict with the pfSense LAN subnet?

    Is pfSense the default gateway for the Nas4free box?

    What IP are you using to connect to the DVR? Is it configured the same as Nas4free?

    You seem to still have 192.168.0.22 in the routing table on the client so that may be conflicting somehow. Seeing the complete route print output would be more useful.

    Steve



  • Thanks steve for your reply,

    yes the route print is from the remote OpenVPN client.
    it's on 192.168.10.X remote not locally locally 19.168.0.0/24

    Is pfSense the default gateway for the Nas4free box? yes it is the default gateway.

    What IP are you using to connect to the DVR? Is it configured the same as Nas4free?
    yes 192.168.0.137 DVR

    You seem to still have 192.168.0.22 in the routing table on the client so that may be conflicting somehow. Seeing the complete route print output would be more useful.

    how to get complete route print?


  • Netgate Administrator

    Just type 'route print' and don't pipe it to find.

    If the DVR is in the same subnet though the same restrictions should apply.

    I would run a ping from the remote client to the NAS the check for states in the pfSense state table (Diag > States). If states are there it's probably a local restriction on the NAS the prevents it responding to requests from the OpenVPN tunnel subnet.

    Steve



  • In the Nas4Free Gui.  Check out the System -> General -> Hosts Allow. 
    Also may be worthwhile to check out the Network -> Firewall tab.



  • @rainmakers99:

    In the Nas4Free Gui.  Check out the System -> General -> Hosts Allow. 
    Also may be worthwhile to check out the Network -> Firewall tab.

    all checked and firewall is disable and the host allow is 192.168.0.0/24 10.0.7.0/24 192.168.10.0/24

    still no reply while ping the nas from remote



  • On your Nas4Free box, do you have the default gateway set?  From the ssh console on the Nas4free can you ping an internet address?

    I ask because when I first setup Nas4Free box, I thought I didn't need to set a gateway on the network interface since it was internal storage only.


  • Netgate Administrator

    @irs:

    still no reply while ping the nas from remote

    And what states did you see in pfSense whilst doing that? You should see states from the remote client IP if the port forwards are working correctly.

    Steve


Log in to reply