LightSquid not working



  • I cannot get lightsquid to work with the 1.2.1 beta.

    Troubleshooting

    • Reinstalled the xml files for both squid and light squid
    • Removed both squid and lightsquid + reinstall
    • Tried pressing refresh, refresh full, save etc, waiting a day etc.
    • Tail -f access.log in squid logs shows data.. and squid is working fine

    It worked perfectly on 1.2, but not on 1.2.1 :(

    Anybody know how to fix this?

    Squid options :

    Transparant proxy enabled
    Lan interface only
    Allow users
    Do not proxy ip enabled for one ip
    enable logging -> enabled
    log dir ->> /var/squid/log
    log rotate 30 days
    the rest is default

    Lighthttp :

    English, blue, DNS, Base theme, 60min refresh schedule (tried to change etc) 30 day log rotation



  • Hello everyone
    I have the same problem with almost same setting.

    Anybody know how to fix this?

    I hope someone response to this request

    Regards,
    SaFi



  • Look this
    http://forum.pfsense.org/index.php/topic,11594.msg67187.html#msg67187

    Please remind, after which event Lightsquid does not work?



  • Using 1.2-RELEASE that I downloaded 3 days ago, I have similar issues with lightsquid. 
    I only have phpsysinfo, squid, and lightsquid packages installed.  Lightsquid reports work,
    but no graphs.  Attempting to access the graphs gives a 500 - Internal Server error.
    When I attempt to run /usr/local/www/lightsquid/graph.cgi from the CLI, I get this:

    Can't locate GD.pm in @INC (@INC contains: /usr/local/lib/perl5/5.8.8/BSDPAN /usr/local/lib/perl5/site_perl/5.8.8/mach /usr/local/lib/perl5/site_perl/5.8.8 /usr/local/lib/perl5/site_perl /usr/local/lib/perl5/5.8.8/mach /usr/local/lib/perl5/5.8.8 .) at ./graph.cgi line 15.
    BEGIN failed–compilation aborted at ./graph.cgi line 15.

    I attempted to install GD via CPAN, but it can't locate libgd.  I thought perhaps I should ask
    before going down this route much further :)

    Again, reports all work fine in lightsquid.  Only attempting to access a graph gives
    me the 500 Internal Server error.

    Any thoughts?



  • first of all I'd like to say big thanks to dvserg, AudiAddict, wilagobler, all of you and I'd like to just reported about what's happened with me.
    the lightsquid return to work again just when I linked perl in the new path as

    ln -s /usr/local/bin/perl /usr/bin/perl
    

    Again, reports all work fine in lightsquid.  Only attempting to access a graph gives
    me the 500 Internal Server error.

    Regarding to graphs I hope deeply to see one day this graph work
    It's never happened with me before even when replaced "libperl.so"



  • I just want to add using the 1.2.1-RC2-1114 release I had to install squid and lightsquid, run SaFi's code then manually uninstall lightsquid, uninstall squid via gui then gui re-install both in order to get lightsquid to work. Before I reinstalled squid aftering manually removing lightsquid the 500 - Internal Server Error went away but I just got a couple lines of text not the lightsquid report as it should be.



  • Any solution to this one? I noticed a update to the official lightsquid site saying that

    ou SHOULD patch lightparser.pl

    #extract site name
          $url =~ m/([a-z]+://)??([a-z0-9-]+.){1}(([a-z0-9-]+.){0,})([a-z0-9-]+){1}(:[0-9]+)?/(.*)/o;
          $site=$2.$3.$5;
          $site=$Lurl if ($site eq "");

    replace to

    #extract site name
          if ($url =~ m/([a-z]+://)??([a-z0-9-]+.){1}(([a-z0-9-]+.){0,})([a-z0-9-]+){1}(:[0-9]+)?/(.*)/o) {
            $site=$2.$3.$5;
          } else {
            $site=$Lurl;
          }

    ESL 2008-11-07. fixed version ASAP …

    Maybe an update has to be done to the package? Lightsquid would be great on my pfsense, since the original squid package does not offer any way to look at the logs without entering the pfsense machine. Or, am I wrong?


Log in to reply