Running NUT on 1.2



  • Hey all! I'm new here but I've been running pfSense 1.2 for the past 3 or 4 months and am loving it! Anyway here's my issue:

    After losing power from the power company, and foolishly not having a UPS, I decided to go out and buy one. Well I've done that, hooked it up, and installed the NUT package in 1.2 stable. I'm getting a message though that says "NUT is enabled, however the service is not running!". I've removed and reinstalled the package (thinking it must not have installed or started up correctly) but it's still giving this error. I've gone thru the logs in the pfsense's GUI but I don't see anything that says the NUT service has failed to start. I also went to Status-Services and sure enough, it's "Stopped". I've hit the play icon to start it, it says it's started across the top of the page, but it's continues to stay in the stopped state. Any ideas of where to look or what to try next?

    And finally, should I use pfSense to manage my UPS or should I use my other server to control it and let pfSense be a slave off of that machine? My other rig is a Linux box so configuring NUT (from the sounds of it) might be a challenge. Thanks!



  • Well…131 reads and one month later...

    So I've upgraded to 1.2.1 RC2 now. I was anxious to see the speed increase and yeah, I can feel it from 1.2! Anyway, with the upgrade, came the anticipation of trying yet again to get NUT working correctly. Boy is this package screwed up.

    I went to install it from the 'packages' and it said it was 2.0.4 Beta. As I'm installing it, I see it installs "nut-2.2.2" which I'm all for as it supports my UPS (so I've heard). I have USB 1 and 2 enabled on my motherboard and I've got the USB cable connected to my UPS. Sure enough...same as above! The service says "stopped" and yet, you click on "start" and it stays in a stopped state...even though it's contradictory message above says "nut has been started"...yeah it hasn't.

    Just my 2 cents, someone might want to look into this package.



  • **I was also having problems with the nut package in 1.2.1 RC2 and a APC ES-350 using a usb cable.
    I was able to resolve the issue by running a search and replace on "nut.xml"  and replacing all instances of "newhidups" with "usbhid-ups"

    Hope that helps
    GP

    P.S as always it would be a good idea to make a backup of "nut.xml" before you start!**



  • gsporter, thanks for the reply!

    Unfortunately though, that didn't work. I created a folder called "backups" in the root directory and saved the nut.inc and nut.xml files there. Next, I used "vi" and looked thru that file (nut.xml) like you said and found my UPS (which I failed to mention earlier – Cyberpower 850AVR, connected via USB). It's value was "cyberpower05" but I recalled the NUT site saying that "cyberpower" would be the name of the driver. I tried that and no luck. Then I changed it (under just my UPSes model, by the way) to "usbhid-ups" like you said and it still says "Stopped" even after I hit "Start" to run the service. Now I'm just lost as to why this isn't working correctly...?



  • Well, for me I replaced newhidups with usbhidups and it still didn't work…until i realized i forgot the dash...usbhid-ups...Now all works well.



  • If this topic is solved then please mark the subject of this post with a [Solved] So that others might see it and use this post to solve their problems.

    However since you guys fixed this problem maybe you can help me with mine. I'm running a APC750 UPS via USB and I have been having the same problem. It won't start the service. I get the same error message that you guys did.

    Any ideas?



  • bump



  • It doesn't seem solved totally for me. One PF box works fine, except that after several hours I'm plagued with Stale data. I've tried changing poll interval which seems to work, but eventually fails after some time. I have to restart Nut to get it back up. On another PF box, I have the same UPS and it won't connect. I have to try a different cable maybe and see if that helps. I've tried a serial to rj-45 cable and that connects fine, but it won't display any info, other than it's online. Basically, still playing with it.

    APC 1500XS



  • Well, as for stale data what seems to work so far is setting up a cron job to restart the driver every 30 minutes….

    Just add to your config:

    <minute>/30</minute>
    <hour>
    </hour>
    <mday></mday>
    <month>
    </month>
    <wday>*</wday>
    <who>root</who>
    <command></command>/usr/local/etc/rc.d/nut.sh start


Log in to reply