System crashes when in production use.



  • I have had pfsense up and running for a number of weeks now with no issues. It was attached to my existing network. Last night I put it in to production as the main firewall and router. It ran for at least 4 hours before I went to sleep. This morning I had no internet access. It looked like the pfsense box was locked up. I rebooted it and everything worked fine for a couple of hours. Then it locked up again. This time it looked like it tried to reboot and locked up part way through. I have removed the box from service. I have a log from the 2nd crash but I see no way to upload it here. I think I am SOL without the ability to upload the log. Although I don't know that the log will be very useful. Thanks.



  • You can attach it to your post or use something like pastebin



  • Thank you. That did not work before. It seems to have crashed again while out of service on the network. I will include the next log if it gives me one.

    [pfsense crash 6-11-17-2.txt](/public/imported_attachments/1/pfsense crash 6-11-17-2.txt)



  • Here is the next one. I'm starting to think it might be half of the ram. I removed 2 of the 4 sticks. I would not think an OS crash would be causing reboots that halt part way through.

    [pfsense crash 6-11-17-3.txt](/public/imported_attachments/1/pfsense crash 6-11-17-3.txt)



  • I'm not very experienced in reading/debugging crahdumps, but I've had a couple 'fatal trap 9' errors over the years:
    It always ended being faulty hardware (mostly ram)



  • Thank you for the help. I think that is indeed the issue. I set up the ipmi and viewed the event logs. I have multiple correctable and uncorrectable memory ecc @ dimm1b(cpu1). That was one of the sticks removed. So far it has been stable. Now to figure out why I can not load speedtest.net and other like sites.



  • @randomuser:

    ….. Now to figure out why I can not load speedtest.net and other like sites.

    Well,
    Your browser should accept cookies, Javascript, it should have "Adobe Flash", your browser (and all filtering devices upfront) should accepts the tons of publicity, the page is sourcing from Facebook, Google and more.



  • Thank you for the tip but its something in the firewall blocking speed test sites. They work fine with the old firewall/router.  I think its snort? I heard it does a lot of false positives. I'm not sure if its that or if its that the speed test site is trying to ping me for latency and that is blocked.



  • Which tool or site are you using for the speed test?



  • The one built into google works although the speed is about 50%. Comcast's also works. Verizon does not and speedtest.net does not. They do not load correctly.



  • This is definitely not the pfSense problem, but snort or any other packages or some settings. Try to whitelist your "blocked" sites in snort.


Log in to reply