Manually install Squid 3.5.3



  • Hi all,
    I have installed pfSense 2.3.4 on a virtual infrastructure. Also, I have installed "squid-3.5.24_2" and "squidguard-1.4_15". I´m facing problems related to the following error:

    _**ERROR

    The requested URL could not be retrieved

    The following error was encountered while trying to retrieve the URL: https://http/*

    Unable to determine IP address from host name “http”

    The DNS server returned:

    Server Failure: The name server was unable to process this query.

    This means that the cache was not able to resolve the hostname presented in the URL. Check if the address is correct.

    Your cache administrator is ocs.engineering@olympicchannel.com.**_

    I think that this problem is reported in the following link:
    https://turbofuture.com/internet/Intercepting-HTTPS-Traffic-Using-the-Squid-Proxy-in-pfSense

    But could someone confirm me if updating the version of squid to 3.5.3 I could fix this problem?.

    I was trying to update manually but I don´t know how can I do this. I tried with "pkg install https://files.pfsense.org/packages/10/All/squid-3.5.3-amd64.pbi" but I receive this other error:

    Updating pfSense-core repository catalogue…
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.
    pkg: No packages available to install matching 'https://files.pfsense.org/packages/10/All/squid-3.5.3-amd64.pbi' have been found in the repositories

    I´m not an expert neither pfsense nor freebsd, so any help will be appreciate.

    In any case, many thanks in advance.

    Regards,

    Raul.



  • Pbi files are for 2.2.x version. They will not work on 2.3.4

    This looks like a squidguard error, not a squid one.

    If you really want to change the squid version on your system, you need to enable freebsd repository or compile it on a bsd and create a package to install.


Log in to reply